summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-25 12:18:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-25 16:17:49 +0200
commitb9162199b344d6fe40efd5841a5593a10194336e (patch)
tree6ec0cadda2abb35956e1c6ed02e77bd6779253aa /gnu/packages
parentb380fbca8859f7ba0f41703a970ddd26b4590eb4 (diff)
downloadguix-b9162199b344d6fe40efd5841a5593a10194336e.tar.gz
gnu: propeller-gcc-4: Use G-expression.
* gnu/packages/embedded.scm (propeller-gcc-4)[arguments]: Use G-expression
because the parent GCC package uses them too.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/embedded.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index fb45e056d7..598b2d078e 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2017, 2018, 2019, 2023 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016, 2017 Theodoros Foradis <theodoros@foradis.org>
 ;;; Copyright © 2016 David Craven <david@craven.ch>
 ;;; Copyright © 2017, 2020 Efraim Flashner <efraim@flashner.co.il>
@@ -738,9 +738,9 @@ with a layered architecture of JTAG interface and TAP support.")
       (arguments
        (substitute-keyword-arguments (package-arguments propeller-gcc-6)
          ((#:phases phases)
-          `(modify-phases ,phases
+          #~(modify-phases #$phases
              (add-after 'unpack 'chdir
-               (lambda _ (chdir "gcc") #t))))))
+               (lambda _ (chdir "gcc")))))))
       (native-inputs
        `(("gcc-4" ,gcc-4.9)
          ,@(package-native-inputs propeller-gcc-6)))