summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-15 23:25:33 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-19 20:12:13 -0400
commitd37747beda04dd900ed83a5d65ccb31118089ac3 (patch)
treed7a4e47bae45a57da1bd405c9b53e378f7c461b2 /gnu/packages
parent66ffbaa409d7ec3901aa64706dcca51085973319 (diff)
downloadguix-d37747beda04dd900ed83a5d65ccb31118089ac3.tar.gz
gnu: python-typing-extensions: Use pyproject-build-system.
* gnu/packages/python-xyz.scm (python-typing-extensions)
[arguments]: Remove #:phases argument.
[native-inputs]: Remove python-pypa-build.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 4 insertions, 20 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f39c09b950..bc3b27d22b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22655,26 +22655,10 @@ with PEP 484 argument (and return) type annotations.")
               (sha256
                (base32
                 "19n4l57qazwrbvxjrbxw2vvfyd0zbk8ivnwm4zmwfzzl69x6glp6"))))
-    (build-system python-build-system)
-    (arguments
-     (list
-      #:tests? #f       ;requires Python's test module, not available in Guix
-      #:phases
-      #~(modify-phases %standard-phases
-          ;; XXX: PEP 517 manual build copied from python-isort.
-          (replace 'build
-            (lambda _
-              (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
-          (replace 'check
-            (lambda* (#:key tests? #:allow-other-keys)
-              (when tests?
-                (invoke "python" "src/test_typing_extensions.py"))))
-          (replace 'install
-            (lambda _
-              (let ((whl (car (find-files "dist" "\\.whl$"))))
-                (invoke "pip" "--no-cache-dir" "--no-input"
-                        "install" "--no-deps" "--prefix" #$output whl)))))))
-    (native-inputs (list python-pypa-build python-flit-core))
+    (build-system pyproject-build-system)
+    ;; The test suite requires Python's test module, not available in Guix.
+    (arguments (list #:tests? #f))
+    (native-inputs (list python-flit-core))
     (home-page "https://github.com/python/typing/typing_extensions")
     (synopsis "Experimental type hints for Python")
     (description