summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-05 04:12:15 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:02 +0200
commitd4d2492ac65ea4300668e852a0fd39ffdb0f9d28 (patch)
tree3f5053f79e2fffb97de70eefc72fe9065196f9cf /gnu/packages
parentf2e3d0a947057feee6de3ba866dc72859fd9b9cc (diff)
downloadguix-d4d2492ac65ea4300668e852a0fd39ffdb0f9d28.tar.gz
gnu: emacs-jinja2-mode: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-jinja2-mode)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 62c06e8e0e..228e4ac1fd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3440,13 +3440,13 @@ insertion mode.  When enabled all keys are implicitly prefixed with
     (version "0.2")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/paradoxxxzero/jinja2-mode/"
-                           "archive/v" version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/paradoxxxzero/jinja2-mode.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "0cgxjab1kla2zc2fj7bzib6i7snp08zshandmp9kqcm85l262xpn"))))
+        (base32 "0l26wcy496k6xk7q5sf905xir0p73ziy6c44is77854lv3y0z381"))))
     (build-system emacs-build-system)
     (home-page "https://github.com/paradoxxxzero/jinja2-mode")
     (synopsis "Major mode for jinja2")