summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-29 10:13:24 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-29 10:57:02 -0500
commitdccaf68ab0634e99eaeb2184bc799535b0ff8235 (patch)
tree950e3eb67bc3a1fecb1786c5f590ce7061d84638 /gnu/packages
parent037615cf7163bdde53d44ddd31fadcc355201c54 (diff)
downloadguix-dccaf68ab0634e99eaeb2184bc799535b0ff8235.tar.gz
gnu: python2-pylint: Remove package.
* gnu/packages/check.scm (python2-pylint): Delete.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/check.scm43
1 files changed, 0 insertions, 43 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index e3e7d44229..248d7f1299 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2193,51 +2193,8 @@ Pylint has many rules enabled by default, way too much to silence them
 all on a minimally sized program.  It's highly configurable and handle
 pragmas to control it from within your code.  Additionally, it is
 possible to write plugins to add your own checks.")
-    (properties `((python2-variant . ,(delay python2-pylint))))
     (license license:gpl2+)))
 
-;; Python2 is not supported anymore by Pylint. See:
-;; https://github.com/PyCQA/pylint/issues/1763.
-(define-public python2-pylint
-  (let ((pylint (package-with-python2
-                 (strip-python2-variant python-pylint))))
-    (package (inherit pylint)
-             (version "1.9.5")
-             (source
-              (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/PyCQA/pylint")
-                      (commit (string-append "pylint-" version))))
-                (file-name (git-file-name (package-name pylint) version))
-                (sha256
-                 (base32
-                  "02a89d8a47s7nfiv1ady3j0sg2sbyja3np145brarfp5x9qxz9x2"))))
-             (arguments
-              `(,@(strip-keyword-arguments '(#:tests?) (package-arguments pylint))
-                #:phases
-                (modify-phases %standard-phases
-                  (replace 'check
-                    (lambda _
-                      ;; Somehow, tests fail if run from the build directory.
-                      (let ((work "/tmp/work"))
-                        (mkdir-p work)
-                        (setenv "PYTHONPATH"
-                                (string-append (getenv "PYTHONPATH") ":" work))
-                        (copy-recursively "." work)
-                        (with-directory-excursion "/tmp"
-                          (invoke "python" "-m" "unittest" "discover"
-                                  "-s" (string-append work "/pylint/test")
-                                  "-p" "*test_*.py"))))))))
-             (native-inputs
-              `(("python2-futures" ,python2-futures)
-                ,@(package-native-inputs pylint)))
-             (propagated-inputs
-              `(("python2-backports-functools-lru-cache"
-                 ,python2-backports-functools-lru-cache)
-                ("python2-configparser" ,python2-configparser)
-                ,@(package-propagated-inputs pylint))))))
-
 (define-public python-paramunittest
   (package
     (name "python-paramunittest")