summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-05-29 16:29:36 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-05-29 16:31:09 +0300
commite4fe344a5c64063f8201a637973aa366a3ded200 (patch)
tree7b9b22cbf04d15ec949b0805ca142541e53c6c7c /gnu/packages
parent50970a28b768c98ed45ed0201e201f5da8d993e4 (diff)
downloadguix-e4fe344a5c64063f8201a637973aa366a3ded200.tar.gz
gnu: nmap: Honor tests? flag.
* gnu/packages/admin.scm (nmap)[arguments]: In custom 'check phase honor
the #:tests? flag.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index af75dee697..4e655551bd 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3191,10 +3191,12 @@ rules is done with the @code{auditctl} utility.")
                    (,(python-path ndiff)))))))
          ;; These are the tests that do not require network access.
          (replace 'check
-           (lambda _ (invoke "make"
-                             "check-nse"
-                             "check-ndiff"
-                             "check-dns"))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "make"
+                       "check-nse"
+                       "check-ndiff"
+                       "check-dns")))))
        ;; Nmap can't cope with out-of-source building.
        #:out-of-source? #f))
     (home-page "https://nmap.org/")