summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-01-27 15:34:41 +0100
committerLudovic Courtès <ludo@gnu.org>2016-01-27 15:48:35 +0100
commite932d371e5ab4b549008e3027c27a2d8259a03d4 (patch)
tree1c3314a28af07722b0c3140ba009bd4a1a03b886 /gnu/packages
parentd114ceebaca88edc9716e6de9949ce20c11a342f (diff)
downloadguix-e932d371e5ab4b549008e3027c27a2d8259a03d4.tar.gz
gnu: Add snapshot of the GNU Shepherd.
* gnu/packages/admin.scm (shepherd): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 953c5b4cf8..8b865ef35e 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -58,7 +58,8 @@
   #:use-module (gnu packages image)
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages python)
-  #:use-module (gnu packages man))
+  #:use-module (gnu packages man)
+  #:use-module (gnu packages autotools))
 
 (define-public dmd
   (let ((base-version "0.2")
@@ -99,6 +100,32 @@ interface and is based on GNU Guile.")
       (license license:gpl3+)
       (home-page "http://www.gnu.org/software/dmd/"))))
 
+(define-public shepherd
+  (let ((commit "bc7757cd1f3d0a162e765d0ecebde052765a6a23"))
+    (package
+      (inherit dmd)
+      (name "shepherd")
+      (version (string-append "0.2-1." (string-take commit 7)))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "git://git.savannah.gnu.org/shepherd.git")
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "0ks4yy6ji1s7id09im5jcwrr4y5ss3244hcy7v504cwf21gdkdgq"))))
+      (arguments
+       `(#:phases (modify-phases %standard-phases
+                    (add-after 'unpack 'autoreconf
+                      (lambda _
+                        (zero? (system* "autoreconf" "-vfi")))))
+                  ,@(package-arguments dmd)))
+      (native-inputs `(("autoconf" ,(autoconf-wrapper))
+                       ("automake" ,automake)
+                       ("texinfo" ,texinfo)
+                       ("help2man" ,help2man)
+                       ,@(package-native-inputs dmd))))))
+
 (define-public dfc
   (package
    (name "dfc")