summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-21 23:34:24 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:46:10 -0400
commit01360c8b02f259f7b3890fc0b6dcd37f33ae4d38 (patch)
tree2b29a0a530c802646fb48559f7ea8877a66358d0 /gnu/packages
parent0efccc8f1881f8272a2eafb5b948047cf8912dec (diff)
downloadguix-01360c8b02f259f7b3890fc0b6dcd37f33ae4d38.tar.gz
gnu: python-sphinxext-opengraph: Update to 0.6.3.
* gnu/packages/sphinx.scm (python-sphinxext-opengraph): Update to 0.6.3.
[phases]{check}: Streamline and invoke pytest verbosely.
[native-inputs]: Indent on a single line.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/sphinx.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 5e0ac96ab6..42eb34810a 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -812,7 +812,7 @@ translate and to apply translation to Sphinx generated document.")
 (define-public python-sphinxext-opengraph
   (package
     (name "python-sphinxext-opengraph")
-    (version "0.4.2")
+    (version "0.6.3")
     (source
      (origin
        (method git-fetch)               ; no tests in PyPI release
@@ -821,18 +821,16 @@ translate and to apply translation to Sphinx generated document.")
              (commit (string-append "v"  version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0dka44wri7agcr1jd641hq6j7qlbycligp80ngf32l5asqz1mgzp"))))
+        (base32 "1wrgpan9z65fv4hbvisz4sypc4w5ammnxkyn5lhr43wdr6b967k1"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+           (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
-               (add-installed-pythonpath inputs outputs)
-               (invoke "python" "-m" "pytest")))))))
-    (native-inputs
-     (list python-beautifulsoup4 python-pytest python-sphinx))
+               (invoke "pytest" "-vv")))))))
+    (native-inputs (list python-beautifulsoup4 python-pytest python-sphinx))
     (home-page "https://github.com/wpilibsuite/sphinxext-opengraph")
     (synopsis "Sphinx Extension to enable OpenGraph support")
     (description