summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2023-09-06 18:25:53 +0800
committerLudovic Courtès <ludo@gnu.org>2023-09-14 22:58:25 +0200
commit258729b928e14f0349a109d0a9a1d56a8e68e139 (patch)
tree85692df1096f3214648a967b69472d03fb7a6f3c /gnu/packages
parent55da0930e30e0ee1b3da1b9aee5851e9ccfca32c (diff)
downloadguix-258729b928e14f0349a109d0a9a1d56a8e68e139.tar.gz
gnu: makefile2graph: fix cross-compile.
* gnu/packages/code.scm (makefile2graph): fix cross-compile.
[arguments]: Use gexp and CC-FOR-TARGET.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/code.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 1c21ad475b..4335c57150 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -17,6 +17,7 @@
 ;;; Copyright © 2021 lu hui <luhuins@163.com>
 ;;; Copyright © 2021, 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
 ;;; Copyright © 2022 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -773,11 +774,13 @@ produce colored output.")
         (base32 "1gjfk3d8qg3cla7qd2y7r9s03whlfwy83q8k76xfcnqrjjfavdgk"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:test-target "test"
-       #:make-flags (list "CC=gcc" (string-append "prefix=" %output))
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure))))
+     (list
+      #:test-target "test"
+      #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+                           (string-append "prefix=" #$output))
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure))))
     (native-inputs
      (list graphviz))
     (home-page "https://github.com/lindenb/makefile2graph")