summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorBrett Gilio <brettg@posteo.net>2019-02-07 22:04:16 -0600
committerLudovic Courtès <ludo@gnu.org>2019-02-12 23:30:16 +0100
commit346c87522ee5cc10c80bea0b5609c7a7f212537d (patch)
treec5c2b15ad6e8a6f52999d39b10cc93ed69e93a43 /gnu/packages
parent2c880ef4e542c0d6aead79f740e140e45f47a855 (diff)
downloadguix-346c87522ee5cc10c80bea0b5609c7a7f212537d.tar.gz
gnu: Add python-jsonrpc-server.
* gnu/packages/python-xyz.scm (python-jsonrpc-server): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0ba9f5266d..959b4647cf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2578,6 +2578,29 @@ which can produce feeds in RSS 2.0, RSS 0.91, and Atom formats.")
 Language (TOML) configuration files.")
     (license license:expat)))
 
+(define-public python-jsonrpc-server
+  (package
+    (name "python-jsonrpc-server")
+    (version "0.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "python-jsonrpc-server" version))
+       (sha256
+        (base32
+         "0m4ykpcdy52x37n1ikysp07j7p8ialcdvvvsrjp3545sn7iiid09"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-future" ,python-future)
+       ("python-mock" ,python-mock)
+       ("python-pytest" ,python-pytest)))
+    (home-page
+     "https://github.com/palantir/python-jsonrpc-server")
+    (synopsis "JSON RPC 2.0 server library")
+    (description
+     "This packages provides a JSON RPC 2.0 server library for Python.")
+    (license license:expat)))
+
 (define-public python-black
   (package
     (name "python-black")