summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-08-18 03:01:50 +0200
committerOleg Pykhalov <go.wigust@gmail.com>2019-08-18 21:00:29 +0300
commit41671813f13cc4965f3674fdf4eb17506b49caf2 (patch)
tree578d712b32564deea5f9dd61c86b090f26a988a1 /gnu/packages
parent317879f555ac945c89423c178e280482f4b1d83d (diff)
downloadguix-41671813f13cc4965f3674fdf4eb17506b49caf2.tar.gz
gnu: Add emacs-frog-jump-buffer.
* gnu/packages/emacs-xyz.scm (emacs-frog-jump-buffer): New variable.

Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4444690e3f..ffc662f746 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10250,6 +10250,34 @@ the same values you get in a terminal.")
 candidates on which user-defined dispatch actions can act.")
       (license license:gpl3+))))
 
+(define-public emacs-frog-jump-buffer
+  (let ((commit "2d7b342785ae27d45f5d252272df6eb773c78e20")
+        (revision "1"))
+    (package
+      (name "emacs-frog-jump-buffer")
+      (version (git-version "0.1.4" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/waymondo/frog-jump-buffer")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1z00by8hiss1r2lwmzrl8pnz6jykia2849dqqm4l3z5rf6lwvc0f"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-dash" ,emacs-dash)
+         ("emacs-frog-menu" ,emacs-frog-menu)
+         ("emacs-avy" ,emacs-avy)))
+      (home-page "https://github.com/waymondo/frog-jump-buffer")
+      (synopsis "Jump to any Emacs buffer with minimal keystrokes")
+      (description
+       "This package provides a preview window of buffers that can be switched
+to with quicklink-style selections.")
+      (license license:gpl3+))))
+
 (define-public emacs-deft
   (package
     (name "emacs-deft")