summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-06-01 09:55:40 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-11 15:19:02 +0200
commit50a1f9264d78487965bbb38a391470914d3122f7 (patch)
tree36633bf952b395e5320bdfef3fff39cc66262e12 /gnu/packages
parent00f3774067bc705d1e9cb885d92858cdccf4631f (diff)
downloadguix-50a1f9264d78487965bbb38a391470914d3122f7.tar.gz
gnu: Add emacs-package-lint.
* gnu/packages/emacs.scm (emacs-package-lint): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index dbcb1e14ba..75b4213f75 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -11175,3 +11175,29 @@ provided by other Emacs packages dealing with pass:
        "Image+ provides keybindings allowing you to zoom in or zoom out of an
 image, rotate it, save modified images, and more.")
       (license license:gpl3+))))
+
+(define-public emacs-package-lint
+  (let ((commit "69bb89d00ba212b734c676ad056aa793c450b288"))
+    (package
+      (name "emacs-package-lint")
+      (version (git-version "0.5" "1" commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/purcell/package-lint")
+               (commit commit)))
+         (file-name (string-append name "-" version "-checkout"))
+         (sha256
+          (base32
+           "1hfricsgmy3x9snnd2p4xq6vnnv94qdsxxnxp07b3hqc9bhw31rq"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/purcell/package-lint")
+      (synopsis "Linting library for elisp package authors")
+      (description
+       "This provides a list of issues with the Emacs package metadata of a file,
+e.g. the package dependencies it requires.  See function
+@code{package-lint-buffer}.  Checks will currently be enabled only if a
+\"Package-Requires:\" or \"Package-Version:\" header is present in the
+file.")
+      (license license:gpl3+))))