summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2021-07-29 16:33:03 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-29 21:54:54 +0200
commit646b5ad9835c4114be9aae415e02b877c957d2d0 (patch)
treeede1ebc7fc9a0b6ab6a4010fd1a54dc0b7069412 /gnu/packages
parent18d04fef0fea2c604b42c465782f3be647c2b947 (diff)
downloadguix-646b5ad9835c4114be9aae415e02b877c957d2d0.tar.gz
gnu: Add googlebenchmark.
* gnu/packages/check.scm (googlebenchmark): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/check.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 637449351a..0d0229330e 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -26,7 +26,7 @@
 ;;; Copyright © 2017 Nikita <nikita@n0.is>
 ;;; Copyright © 2015, 2017, 2018, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2017, 2018, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2017, 2018, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
 ;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2019 Chris Marusich <cmmarusich@gmail.com>
@@ -712,6 +712,33 @@ generation.")
               (base32
                "0270msj6n7mggh4xqqjp54kswbl7mkcc8px1p5dqdpmw5ngh9fzk"))))))
 
+(define-public googlebenchmark
+  (package
+    (name "googlebenchmark")
+    (version "1.5.3")
+    (home-page "https://github.com/google/benchmark")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference (url home-page)
+                                  (commit (string-append "v" version))))
+              (file-name (git-file-name "google-benchmark" version))
+              (sha256
+               (base32
+                "1hls0aqqj5cfldn9jfpvzjhpxkhrydrz9crp477rwllwjsybdxw7"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON"
+                               (string-append
+                                "-DGOOGLETEST_PATH="
+                                (assoc-ref %build-inputs "googletest")))))
+    (inputs
+     `(("googletest" ,(package-source googletest))))
+    (synopsis "C++ library to support the benchmarking of functions")
+    (description
+     "The googlebenchmark C++ library support the benchmarking of functions,
+similar to unit tests.")
+    (license license:asl2.0)))
+
 (define-public cpputest
   (package
     (name "cpputest")