summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-11-24 11:01:01 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-11-24 11:01:01 +0100
commit6605d9ba356f7975e75c0664d9ef02bb7bc9cc1e (patch)
tree129befdc98edb1d1a425c0ea9490a6e173b265e6 /gnu/packages
parentd5de4e163ccef80f78bc5fe330f568d8fe3a23ab (diff)
downloadguix-6605d9ba356f7975e75c0664d9ef02bb7bc9cc1e.tar.gz
gnu: asymptote: Fix build.
* gnu/packages/plotutils.scm (asymptote)[native-inputs]: Add
texlive-dvips-l3backend, texlive-fonts-ec, texlive-generic-infwarerr,
texlive-generic-kvdefinekeys, texlive-grfext, texlive-latex-kvoptions,
texlive-latex-pdftexcmds.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/plotutils.scm26
1 files changed, 17 insertions, 9 deletions
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 14522491f4..fb4bd2f8b6 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -221,15 +221,23 @@ colors, styles, options and details.")
        ("perl" ,perl)
        ("texinfo" ,texinfo)             ;For generating documentation
        ;; For the manual and the tests.
-       ("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
-                                        texlive-epsf
-                                        texlive-etoolbox
-                                        texlive-latex-base
-                                        texlive-latex-geometry
-                                        texlive-latex-graphics
-                                        texlive-oberdiek ;for ifluatex
-                                        texlive-latex-parskip
-                                        texlive-tex-texinfo)))))
+       ("texlive" ,(texlive-updmap.cfg
+                    (list texlive-amsfonts
+                          texlive-dvips-l3backend
+                          texlive-epsf
+                          texlive-etoolbox
+                          texlive-fonts-ec
+                          texlive-generic-infwarerr
+                          texlive-generic-kvdefinekeys
+                          texlive-grfext
+                          texlive-latex-base
+                          texlive-latex-geometry
+                          texlive-latex-graphics
+                          texlive-latex-kvoptions
+                          texlive-latex-pdftexcmds
+                          texlive-oberdiek ;for ifluatex
+                          texlive-latex-parskip
+                          texlive-tex-texinfo)))))
     (inputs
      `(("fftw" ,fftw)
        ("freeglut" ,freeglut)