summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2023-10-05 21:34:47 +0000
committerLudovic Courtès <ludo@gnu.org>2023-10-06 12:26:45 +0200
commit913e2dd61f175ee8782c608b8c2339e8ae6b24bd (patch)
tree196aa0c3363261030002cd9a7b630e116afd7c9a /gnu/packages
parent2eb40f8b398cdcc82656d2450b5bb7e79193d474 (diff)
downloadguix-913e2dd61f175ee8782c608b8c2339e8ae6b24bd.tar.gz
gnu: Add suitesparse-btf.
* gnu/packages/maths.scm (suitesparse-btf): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 2216cc67b8..1b1a39688b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5168,6 +5168,39 @@ package contains a library with common configuration options.")
 to Cholesky factorization (or for LU factorization with diagonal pivoting).")
     (license license:bsd-3)))
 
+(define-public suitesparse-btf
+  (package
+    (name "suitesparse-btf")
+    (version "2.2.0")
+    (source suitesparse-source)
+    (build-system cmake-build-system)
+    (arguments
+     (list
+      #:tests? #f
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'chdir
+            (lambda _
+              (chdir "BTF")))
+          (add-after 'chdir 'set-cmake-module-path
+            (lambda _
+              (substitute* "CMakeLists.txt"
+                (("set.*CMAKE_MODULE_PATH.*")
+                 (string-append "set(CMAKE_MODULE_PATH "
+                                #$suitesparse-config "/lib/cmake/SuiteSparse)\n"
+                                "set(DUMMY\n")))))
+          (replace 'install-license-files
+            (lambda _
+              (install-file "../BTF/Doc/License.txt"
+                            (string-append #$output "/share/doc/"
+                                           #$name "-" #$version)))))))
+    (inputs (list suitesparse-config))
+    (home-page "https://people.engr.tamu.edu/davis/suitesparse.html")
+    (synopsis "Library for permuting matrices into block upper triangular form")
+    (description "BTF (Block Triangular Form) is a C library for permuting a
+matrix into block upper triangular form.")
+    (license license:lgpl2.1+)))
+
 (define-public suitesparse
   (package
     (name "suitesparse")