summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:50:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:27 +0200
commit949c40d590b613fa17cd4aaf82c07d4db7f50198 (patch)
tree38a93d99ac4ad42a8194e2ae629e347845e9bf99 /gnu/packages
parentb57ec8314b295d570804f801b2c898ae2812a9e4 (diff)
downloadguix-949c40d590b613fa17cd4aaf82c07d4db7f50198.tar.gz
gnu: Add texlive-statistics.
* gnu/packages/tex.scm (texlive-statistics): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7361b876c7..b94a10653c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6325,6 +6325,33 @@ presentations.  It represents a syntax-incompatible upgrade of
 @code{statex}.")
     (license license:lppl)))
 
+(define-public texlive-statistics
+  (package
+    (name "texlive-statistics")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/statistics/"
+                   "source/latex/statistics/"
+                   "tex/latex/statistics/")
+             (base32
+              "0cdajj4fclsqcjfc46n82vi8d276qxqklpvdn4gm36dgckrrxaxf")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/statistics")
+    (synopsis "Compute and typeset statistics tables and graphics")
+    (description
+     "The @code{statistics} package can compute and typeset statistics like frequency tables,
+cumulative distribution functions (increasing or decreasing, in frequency or
+absolute count domain), from the counts of individual values, or ranges, or
+even the raw value list with repetitions.  It can also compute and draw a bar
+diagram in case of individual values, or, when the data repartition is known
+from ranges, an histogram or the continuous cumulative distribution function.
+You can ask @code{statistics} to display no result, selective results or all
+of them.  Similarly @code{statistics} can draw only some parts of the
+graphs.")
+    (license license:gpl3+)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")