summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTomas Volf <wolf@wolfsden.cz>2023-10-24 16:47:52 +0200
committerJohn Kehayias <john.kehayias@protonmail.com>2023-10-26 12:04:01 -0400
commita69dec71493c1ecf06071d3304038f3648de69c4 (patch)
treea6acd5dbe94a204791b6bdb9787bd92b1c08e2fd /gnu/packages
parent33f5b747b4a0a508e1ffc94a5bf425cff707c6e3 (diff)
downloadguix-a69dec71493c1ecf06071d3304038f3648de69c4.tar.gz
gnu: Add rust-cbindgen-0.26.
* gnu/packages/rust-apps.scm (rust-cbindgen-0.26): New variable.
(rust-cbindgen-0.24): Inherit from rust-cbindgen-0.26.

Change-Id: Id17f8e251ceecc8ae0708dcfc19acfc5c56b824f
Signed-off-by: John Kehayias <john.kehayias@protonmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/rust-apps.scm58
1 files changed, 34 insertions, 24 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 4a4247751b..a06447143a 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -1370,35 +1370,45 @@ rebase.")
      "This package provides a tool for generating C/C++ bindings to Rust code.")
     (license license:mpl2.0)))
 
-(define-public rust-cbindgen-0.24
+(define-public rust-cbindgen-0.26
   (package
     (inherit rust-cbindgen)
     (name "rust-cbindgen")
+    (version "0.26.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "cbindgen" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0jdbxmn5h5nlr4bifx85gny309djv5djs9q78fa1d7sj0wdw2sys"))))
+    (arguments
+     `(#:cargo-inputs (("rust-clap" ,rust-clap-3)
+                       ("rust-heck" ,rust-heck-0.4)
+                       ("rust-indexmap" ,rust-indexmap-1)
+                       ("rust-log" ,rust-log-0.4)
+                       ("rust-proc-macro2" ,rust-proc-macro2-1)
+                       ("rust-quote" ,rust-quote-1)
+                       ("rust-serde" ,rust-serde-1)
+                       ("rust-serde-json" ,rust-serde-json-1)
+                       ("rust-syn" ,rust-syn-1)
+                       ("rust-tempfile" ,rust-tempfile-3)
+                       ("rust-toml" ,rust-toml-0.5))
+       #:cargo-development-inputs (("rust-serial-test" ,rust-serial-test-0.5))))
+    (native-inputs (list python-cython))))
+
+(define-public rust-cbindgen-0.24
+  (package
+    (inherit rust-cbindgen-0.26)
+    (name "rust-cbindgen")
     (version "0.24.3")
     (source (origin
-             (method url-fetch)
-             (uri (crate-uri "cbindgen" version))
-             (file-name (string-append name "-" version ".tar.gz"))
-             (sha256
-              (base32
-               "1yqxqsz2d0cppd8zwihk2139g5gy38wqgl9snj6rnk8gyvnqsdd6"))))
-    (arguments
-     `(#:cargo-inputs
-       (("rust-clap" ,rust-clap-3)
-        ("rust-heck" ,rust-heck-0.4)
-        ("rust-indexmap" ,rust-indexmap-1)
-        ("rust-log" ,rust-log-0.4)
-        ("rust-proc-macro2" ,rust-proc-macro2-1)
-        ("rust-quote" ,rust-quote-1)
-        ("rust-serde" ,rust-serde-1)
-        ("rust-serde-json" ,rust-serde-json-1)
-        ("rust-syn" ,rust-syn-1)
-        ("rust-tempfile" ,rust-tempfile-3)
-        ("rust-toml" ,rust-toml-0.5))
-        #:cargo-development-inputs
-        (("rust-serial-test" ,rust-serial-test-0.5))))
-    (native-inputs
-     (list python-cython))))
+              (method url-fetch)
+              (uri (crate-uri "cbindgen" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1yqxqsz2d0cppd8zwihk2139g5gy38wqgl9snj6rnk8gyvnqsdd6"))))))
 
 (define-public rust-cbindgen-0.23
   (package