summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorFilip Lajszczak <filip@lajszczak.dev>2023-11-25 19:12:22 +0000
committerMathieu Othacehe <othacehe@gnu.org>2023-11-26 14:48:31 +0100
commitc34b630c99a21fac1a37369c2272aa650c9b1b90 (patch)
tree3cdf4352c612228f4dfaad4c98d0924bd385bfcb /gnu/packages
parent513bf164592e2b44e3e556cc5099a19bd6977790 (diff)
downloadguix-c34b630c99a21fac1a37369c2272aa650c9b1b90.tar.gz
gnu: Add guile-algorithms
Guile port of racket-algorithms

* gnu/packages/guile-xyz.scm (guile-algorithms): New variable.

Change-Id: I53e5b130f96ce10e52622fcdb35b9d0bbe28b108
Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/guile-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 7326c1b65b..557589d2bb 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1373,6 +1373,31 @@ non-mutating insert, delete, and search operations, with support for
 convenient nested tree operations.")
     (license license:gpl3+)))
 
+(define-public guile-algorithms
+  (package
+    (name "guile-algorithms")
+    (version "0.1")
+      (source
+        (origin
+          (method git-fetch)
+          (uri (git-reference
+                 (url "https://git@git.sr.ht/~filiplajszczak/guile-algorithms")
+                 (commit (string-append "v" version))))
+          (file-name (git-file-name name version))
+          (sha256
+            (base32
+             "1a4ffnnhw92gqphjji5ajy3xfaqzww7xv3h8p82gkawx0rqvj5ni"))))
+    (build-system gnu-build-system)
+    (native-inputs (list autoconf automake pkg-config texinfo))
+    (inputs (list guile-3.0))
+    (synopsis "Guile port of racket-algorithms")
+    (description
+     "Guile port of @url{https://docs.racket-lang.org/algorithms/index.html,
+racket-algorithms}, a package containing useful algorithms borrowed from other
+programming languages).")
+    (home-page "https://guile-algorithms.lajszczak.dev/")
+    (license license:gpl3+)))
+
 (define-public guile-aws
   (let ((commit "f32bea12333e1054b97ab50e58a72636edabb5b7")
         (revision "1"))