summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-10-12 23:00:26 +0000
committerAlex Kost <alezost@gmail.com>2016-10-13 22:31:51 +0300
commitce74e520115a6d51b237a953fdf1468bc2b54d44 (patch)
tree67eced5d1c46e934648dc45e27359d805f00df04 /gnu/packages
parent41935673252a00a859a9ab8132d52eecf420823b (diff)
downloadguix-ce74e520115a6d51b237a953fdf1468bc2b54d44.tar.gz
gnu: Add emacs-goto-chg.
* gnu/packages/emacs.scm (emacs-goto-chg): New variable.

Co-authored-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 1b345dba1f..1228ab26b5 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -12,7 +12,7 @@
 ;;; Copyright © 2016 David Thompson <davet@gnu.org>
 ;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
 ;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
-;;; Copyright © 2016 ng0 <ngillmann@runbox.com>
+;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
 ;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2016 Alex Vong <alexvong1995@gmail.com>
@@ -2981,6 +2981,29 @@ Lua programing language}.")
 news items, openrc and runscripts.")
     (license license:gpl2+)))
 
+(define-public emacs-goto-chg
+  (package
+    (name "emacs-goto-chg")
+    (version "1.6")
+    (source
+     (origin
+       (method url-fetch)
+       ;; There is no versioned source.
+       (uri "https://www.emacswiki.org/emacs/download/goto-chg.el")
+       (sha256
+        (base32
+         "078d6p4br5vips7b9x4v6cy0wxf6m5ij9gpqd4g33bryn22gnpij"))))
+    (build-system emacs-build-system)
+    ;; There is no other home page.
+    (home-page "https://www.emacswiki.org/emacs/goto-chg.el")
+    (synopsis "Go to the last change in the Emacs buffer")
+    (description
+     "This package provides @code{M-x goto-last-change} command that goes to
+the point of the most recent edit in the current Emacs buffer.  When repeated,
+go to the second most recent edit, etc.  Negative argument, @kbd{C-u -}, is
+used for reverse direction.")
+    (license license:gpl2+)))
+
 (define-public emacs-writegood-mode
   (package
     (name "emacs-writegood-mode")