summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSughosha <sughosha@proton.me>2023-02-02 12:08:56 +0100
committerLudovic Courtès <ludo@gnu.org>2023-02-11 00:09:40 +0100
commitdaad1dedd74105674fd0c4692b1f2061a767c40f (patch)
tree4e276101d9e6cad6060de26c5f01915c6d6e1b28 /gnu/packages
parenta404f5b64067d175410714a9a6819c8de3b4cd4a (diff)
downloadguix-daad1dedd74105674fd0c4692b1f2061a767c40f.tar.gz
gnu: Add libopenglrecorder.
* gnu/packages/gl.scm (libopenglrecorder): New public variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gl.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 01ab6135a4..09aafcc1c3 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -796,6 +796,32 @@ Both GLX and EGL are supported, in any combination with OpenGL and OpenGL ES.")
                    license:x11
                    license:expat))))
 
+(define-public libopenglrecorder
+  (package
+    (name "libopenglrecorder")
+    (version "0.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/Benau/libopenglrecorder")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0sfx2kdw2mca3mx4fnk1yy74pilp2i9npcpyj894qkngz5aaz2wl"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:tests? #f)) ;no test suite
+    (native-inputs (list pkg-config))
+    (inputs (list libjpeg-turbo))
+    (home-page "https://github.com/Benau/libopenglrecorder")
+    (synopsis "Async readback OpenGL frame buffer with audio recording")
+    (description
+     "libopenglrecorder is a library allowing optional async readback OpenGL
+frame buffer with optional audio recording.  It will do video and audio
+encoding together.")
+    (license license:bsd-3)))
+
 (define-public soil
   (package
     (name "soil")