summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-07-13 16:05:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-07-13 16:06:22 +0200
commite1a8100936f297b2e645de5cf1bd8b390d26bc72 (patch)
treee9f33801f6f5f49a87256cd5ebdceac36cc4b894 /gnu/packages
parentf6b18b53722d8ce5a3f0c961a95015a204c95b62 (diff)
downloadguix-e1a8100936f297b2e645de5cf1bd8b390d26bc72.tar.gz
gnu: emacs-hyperbole: Improve package style.
* gnu/packages/emacs-xyz.scm (emacs-hyperbole)[arguments]: Use G-expressions.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm54
1 files changed, 26 insertions, 28 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0cc6797024..7abd3cf1f5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -604,34 +604,32 @@ uploading PlatformIO projects.")
         (base32 "171x7jad62xd0n3xgs32dksyhn5abxj1kna0qgm65mm0v73hrv8d"))))
     (build-system emacs-build-system)
     (arguments
-     `(#:include (cons* "DEMO"
-                        "DEMO-ROLO.otl"
-                        "HY-ABOUT"
-                        "man/hkey-help.txt"
-                        "\\.kotl$"
-                        %default-include)
-       #:phases
-       (modify-phases %standard-phases
-         ;; Fix build issues about missing "domainname" and "hpmap:dir-user"
-         ;; parent dir, and missing require in "hgnus.el" (void-function:
-         ;; var-append).
-         (add-after 'unpack 'fix-build
-           (lambda* (#:key inputs #:allow-other-keys)
-             (substitute* "hypb.el"
-               (("/bin/domainname")
-                (search-input-file inputs "bin/dnsdomainname")))
-             (substitute* "hyperbole.el"
-               (("\\(hyperb:check-dir-user\\)") ""))
-             (substitute* "hgnus.el"
-               (("hmail ") "hmail hvar "))))
-         (add-after 'install 'install-images
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (for-each (lambda (file)
-                           (install-file
-                            file
-                            (string-append out "/share/info/im")))
-                         (find-files "man/im" "\\.png$"))))))))
+     (list #:include #~(cons* "DEMO"
+                              "DEMO-ROLO.otl"
+                              "HY-ABOUT"
+                              "man/hkey-help.txt"
+                              "\\.kotl$"
+                              %default-include)
+           #:phases
+           #~(modify-phases %standard-phases
+               ;; Fix build issues about missing "domainname" and
+               ;; "hpmap:dir-user" parent dir, and missing require in
+               ;; "hgnus.el" (void-function: var-append).
+               (add-after 'unpack 'fix-build
+                 (lambda* (#:key inputs #:allow-other-keys)
+                   (substitute* "hypb.el"
+                     (("/bin/domainname")
+                      (search-input-file inputs "bin/dnsdomainname")))
+                   (substitute* "hyperbole.el"
+                     (("\\(hyperb:check-dir-user\\)") ""))
+                   (substitute* "hgnus.el"
+                     (("hmail ") "hmail hvar "))))
+               (add-after 'install 'install-images
+                 (lambda _
+                   (let ((dir (string-append #$output "/share/info/im")))
+                     (for-each (lambda (file)
+                                 (install-file file dir))
+                               (find-files "man/im" "\\.png$"))))))))
     (inputs
      (list inetutils))
     (home-page "https://www.gnu.org/software/hyperbole/")