summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-12-29 09:49:32 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-12-29 09:49:32 +0200
commite79a07bcc7f1c09eb3deefd611e7f87c082dfd6d (patch)
tree952655fae75eaecefd517583aa053fee59d67eb7 /gnu/packages
parent34085eabccb8a0ca280f8d1605fdf369a94dd88a (diff)
downloadguix-e79a07bcc7f1c09eb3deefd611e7f87c082dfd6d.tar.gz
gnu: curseradio: Link to mpv.
This fixes https://debbugs.gnu.org/cgi/bugreport.cgi?bug=38789

* gnu/packages/music.scm (curseradio)[arguments]: Add phase to hardcode
path of mpv.
[propagated-inputs]: Move mpv ...
[inputs]: ... to here.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/music.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 6d17de9960..9cd1c17a99 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2569,11 +2569,21 @@ socket or command line.")
                  (base32
                   "11bf0jnj8h2fxhpdp498189r4s6b47vy4wripv0z4nx7lxajl88i"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'link-to-mpv
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "curseradio/curseradio.py"
+               (("/usr/bin/mpv")
+                (string-append (assoc-ref inputs "mpv") "/bin/mpv")))
+             #t)))))
     (propagated-inputs
      `(("python-lxml" ,python-lxml)
        ("python-requests" ,python-requests)
-       ("python-pyxdg" ,python-pyxdg)
-       ("mpv" ,mpv)))
+       ("python-pyxdg" ,python-pyxdg)))
+    (inputs
+     `(("mpv" ,mpv)))
     (home-page "https://github.com/chronitis/curseradio")
     (synopsis "Command-line Internet radio player")
     (description "Curseradio is a Curses-based radio player that uses a