summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-30 03:38:25 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-30 03:46:20 +0200
commit0f6dc120cadfe94110467072d5c6f23357173b95 (patch)
treea4413040666281efdd993392ddc3732467070520 /gnu/packages
parentb414cf523bcb90182403e7cf79aa7093c272eacf (diff)
downloadguix-0f6dc120cadfe94110467072d5c6f23357173b95.tar.gz
gnu: slepc: Return #t from all phases.
* gnu/packages/maths.scm (slepc)[arguments]: Return #t rather than
undefined from phases.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 8b4034a12e..f3ada33e08 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1755,7 +1755,8 @@ savings are consistently > 5x.")
           ;; documentation is difficult.
           (lambda* (#:key outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out")))
-              (for-each delete-file (find-files out "\\.html$")))))
+              (for-each delete-file (find-files out "\\.html$"))
+              #t)))
          (add-after 'install 'clean-install
           ;; Clean up unnecessary build logs from installation.
           (lambda* (#:key outputs #:allow-other-keys)
@@ -1766,7 +1767,8 @@ savings are consistently > 5x.")
                               (delete-file f))))
                         '("configure.log" "make.log" "gmake.log"
                           "test.log" "error.log" "RDict.db"
-                          "uninstall.py"))))))))
+                          "uninstall.py"))
+              #t))))))
     (home-page "http://slepc.upv.es")
     (synopsis "Scalable library for eigenproblems")
     (description "SLEPc is a software library for the solution of large sparse