summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorGabriel Hondet <gabrielhondet@gmail.com>2019-01-03 08:45:36 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-01-16 20:08:28 +0100
commit7cca1fd4007277eb7c2cc7a0f8df76bfd381e05d (patch)
treec116048e22e40a115c56911873b8dc6ad6a41251 /gnu/packages
parent7726124ae20e371fd95917cf4a7b4f621b0f5220 (diff)
downloadguix-7cca1fd4007277eb7c2cc7a0f8df76bfd381e05d.tar.gz
gnu: Add ocaml-sexplib.
* gnu/packages/ocaml.scm (ocaml-sexplib): New variable.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 9103dd94a8..a44cfa0c37 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4936,3 +4936,30 @@ This library is portable and doesn't provide IO functions.  To read
 s-expressions from files or other external sources, you should use
 parsexp_io.")
     (license license:expat)))
+
+(define-public ocaml-sexplib
+  (package
+    (name "ocaml-sexplib")
+    (version "0.11.0")
+    (home-page "https://github.com/janestreet/sexplib")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url (string-append home-page ".git"))
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1qfl0m04rpcjvc4yw1hzh6r16jpwmap0sa9ax6zjji67dz4szpyb"))))
+    (build-system dune-build-system)
+    (inputs
+     `(("ocaml-num" ,ocaml-num)
+       ("ocaml-parsexp" ,ocaml-parsexp)
+       ("ocaml-sexplib0" ,ocaml-sexplib0)))
+    (synopsis
+     "Library for serializing OCaml values to and from S-expressions")
+    (description
+     "This package is part of Jane Street's Core library. Sexplib contains
+functionality for parsing and pretty-printing s-expressions.")
+    (license license:expat)))