summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-02-13 18:04:18 -0800
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-02-21 18:59:30 -0800
commite08739c3c6d5e1fe7bf5c28a889a50086fb873db (patch)
treef16474b0ce344348a958e6ca27ecf00d8d2a6acd /gnu/packages
parentaf5a4602222089ac7e7fdb2c75f2dd00dd305630 (diff)
downloadguix-e08739c3c6d5e1fe7bf5c28a889a50086fb873db.tar.gz
gnu: Add python2-apipkg.
* gnu/packages/python.scm (python2-apipkg): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ac4e4fc8b7..5eaaa8c252 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6850,7 +6850,15 @@ applications.")
 package and greatly reduce the number of imports for your users.  It is a small
 pure Python module that works on virtually all Python versions.")
     (home-page "https://bitbucket.org/hpk42/apipkg")
-    (license license:expat)))
+    (license license:expat)
+    (properties `((python2-variant . ,(delay python2-apipkg))))))
+
+(define-public python2-apipkg
+  (package
+    (inherit (package-with-python2
+              (strip-python2-variant python-apipkg)))
+    (native-inputs
+     `(("python2-setuptools" ,python2-setuptools)))))
 
 (define-public python-execnet
   (package