summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-07-30 16:54:37 +0200
committerPierre Neidhardt <ambrevar@gmail.com>2018-08-14 12:00:18 +0200
commita87ee0e41cb840ec6b5c58cca1e1598b770cef24 (patch)
tree06ecea0ab9c71c82a23e22d49f012841aac3fd46 /gnu/packages
parent5bd3134e04ae91fdefe46d112bad07e996f50e66 (diff)
downloadguix-a87ee0e41cb840ec6b5c58cca1e1598b770cef24.tar.gz
gnu: Add hcxdumptool.
* gnu/packages/networking.scm (hcxdumptool): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/networking.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 5d71494259..371a93566a 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2144,3 +2144,36 @@ Ethernet and TAP interfaces is supported.  Packet capture is also supported.")
        "This package contains a small set of tools to capture and convert
 packets from wireless devices for use with hashcat or John the Ripper.")
       (license license:expat))))
+
+(define-public hcxdumptool
+  (let* ((commit "f4799b5da82c5b030a6d99b02d1c1b9dc838ad36"))
+    (package
+      (name "hcxdumptool")
+      (version (git-version "0.0.0" "1" commit))
+      (home-page "https://github.com/ZerBea/hcxdumptool")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url home-page)
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "0qlsin0rws9sshn12faq4spmd0ffzssal36s71vhv6gkhhga7abl"))
+                (file-name (git-file-name name version))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:make-flags (list "CC=gcc"
+                            (string-append "INSTALLDIR=" (assoc-ref %outputs "out") "/bin"))
+         #:tests? #f                    ;no tests
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'configure))))
+      (synopsis "Small tool to capture packets from wlan devices")
+      (description
+       "Small tool to capture packets from WLAN devices.  After capturing,
+upload the \"uncleaned\" cap to @url{https://wpa-sec.stanev.org/?submit} to
+see if the access point or the client is vulnerable to a dictionary attack.
+Convert the cap file to hccapx format and/or to WPA-PMKID-PBKDF2
+hashline (16800) with @command{hcxpcaptool} from the @code{hcxtools} package
+and check if the WLAN key or the master key was transmitted unencrypted.")
+      (license license:expat))))