summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-06 16:47:54 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-19 19:48:49 -0500
commit9151712c55c573277d97aceb66dac53c8ce488f4 (patch)
tree777dc6cc1000337f07d7965a587bd889bcffb37e /gnu/packages
parent1cebf8736e3ef5bd8d1fbd2bcf7ed0ff009cb619 (diff)
downloadguix-9151712c55c573277d97aceb66dac53c8ce488f4.tar.gz
gnu: Add DateTime-Format-HTTP.
* gnu/packages/web.scm (perl-datetime-format-http): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/web.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 397bacb8af..991ec69f86 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1323,6 +1323,28 @@ parameter parsing, file upload, cookie handling and header generation.")
 inputs, in a manner reminiscent of how PHP does.")
     (license l:bsd-2)))
 
+(define-public perl-datetime-format-http
+  (package
+    (name "perl-datetime-format-http")
+    (version "0.42")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/C/CK/CKRAS/"
+                           "DateTime-Format-HTTP-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0h6qqdg1yzqkdxp7hqlp0qa7d1y64nilgimxs79dys2ryjfpcknh"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-datetime" ,perl-datetime)
+       ("perl-http-date" ,perl-http-date)))
+    (home-page "http://search.cpan.org/dist/DateTime-Format-HTTP")
+    (synopsis "Date conversion routines")
+    (description "This module provides functions that deal with the date
+formats used by the HTTP protocol.")
+    (license (package-license perl))))
+
 (define-public perl-encode-locale
   (package
     (name "perl-encode-locale")