summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-06 15:45:10 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-19 19:48:49 -0500
commitbdcfd18e4bee27a8a3d80e262084be0fab8519fc (patch)
tree90a908f2663c5969024913750715435ed57b2d92 /gnu/packages
parentbec820d94adb5db778e9c81434a1d2b35b2fb7ec (diff)
downloadguix-bdcfd18e4bee27a8a3d80e262084be0fab8519fc.tar.gz
gnu: Add LWP-Protocol-https.
* gnu/packages/web.scm (perl-lwp-protocol-https): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index a918841286..397bacb8af 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1888,6 +1888,31 @@ media types is defined by the media.types file.  If the ~/.media.types file
 exists it is used instead.")
     (home-page "http://search.cpan.org/~gaas/LWP-MediaTypes/")))
 
+(define-public perl-lwp-protocol-https
+  (package
+    (name "perl-lwp-protocol-https")
+    (version "6.06")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/M/MS/MSCHILLI/"
+                           "LWP-Protocol-https-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1vxdjqj4bwq56m9h1bqqwkk3c6jr76f2zqzvwa26yjng3p686v5q"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-io-socket-ssl" ,perl-io-socket-ssl)
+       ("perl-libwww" ,perl-libwww)
+       ;; Users should instead make sure SSL_ca_path is set properly.
+       ;; ("perl-mozilla-ca" ,perl-mozilla-ca)
+       ("perl-net-http" ,perl-net-http)))
+    (home-page "http://search.cpan.org/dist/LWP-Protocol-https")
+    (synopsis "HTTPS support for LWP::UserAgent")
+    (description "The LWP::Protocol::https module provides support for using
+https schemed URLs with LWP.")
+    (license (package-license perl))))
+
 (define-public perl-net-http
   (package
     (name "perl-net-http")