summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-03-16 13:11:28 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-03-16 13:11:28 +0200
commit4cacd87e4d4b72945c19e993eef7af387fce957c (patch)
tree2f54fc1752941a849fa92c3f3a8bbb195e54b754 /gnu/packages
parent56f76b08be97549dcc409b090186103413dc4e4b (diff)
parent0f03c5316819385f3a4047ae50736b3db760f451 (diff)
downloadguix-4cacd87e4d4b72945c19e993eef7af387fce957c.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm4
-rw-r--r--gnu/packages/bioinformatics.scm37
-rw-r--r--gnu/packages/code.scm14
-rw-r--r--gnu/packages/compression.scm85
-rw-r--r--gnu/packages/conky.scm2
-rw-r--r--gnu/packages/cryptsetup.scm4
-rw-r--r--gnu/packages/debug.scm14
-rw-r--r--gnu/packages/emacs.scm2
-rw-r--r--gnu/packages/engineering.scm14
-rw-r--r--gnu/packages/finance.scm4
-rw-r--r--gnu/packages/games.scm51
-rw-r--r--gnu/packages/guile.scm8
-rw-r--r--gnu/packages/mail.scm4
-rw-r--r--gnu/packages/man.scm6
-rw-r--r--gnu/packages/maths.scm4
-rw-r--r--gnu/packages/messaging.scm107
-rw-r--r--gnu/packages/networking.scm25
-rw-r--r--gnu/packages/python.scm16
18 files changed, 326 insertions, 75 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 34f6c222ce..1be2f88d36 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -908,9 +908,7 @@ commands and their arguments.")
                            (man8 (string-append man "/man8")))
                       (define (copy-man-page target)
                         (lambda (file)
-                          (copy-file file
-                                     (string-append target "/"
-                                                    (basename file)))))
+                          (install-file file target)))
 
                       (mkdir-p man5) (mkdir man8)
                       (for-each (copy-man-page man5)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 239b94b6c4..3387a2571a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -151,11 +151,9 @@ and several other tools.")
                            (bin (string-append out "/bin"))
                            (man (string-append out "/share/man/man1")))
                       (mkdir-p bin)
-                      (copy-file "aragorn"
-                                 (string-append bin "/aragorn"))
+                      (install-file "aragorn" bin)
                       (mkdir-p man)
-                      (copy-file "aragorn.1"
-                                 (string-append man "/aragorn.1")))
+                      (install-file "aragorn.1" man))
                     #t)))))
     (home-page "http://mbio-serv2.mbioekol.lu.se/ARAGORN")
     (synopsis "Detect tRNA, mtRNA and tmRNA genes in nucleotide sequences")
@@ -1700,15 +1698,16 @@ gene predictor designed to work with assembled, aligned RNA-seq transcripts.")
          (replace
           'install
           (lambda* (#:key outputs #:allow-other-keys)
-            (let ((out (assoc-ref outputs "out")))
+            (let* ((out (assoc-ref outputs "out"))
+                   (bin (string-append out "/bin")))
               (copy-recursively "src" (string-append out "/src"))
-              (mkdir (string-append out "/bin"))
+              (mkdir bin)
               ;; Add "src" directory to module lookup path.
               (substitute* "couger"
                 (("from argparse")
                  (string-append "import sys\nsys.path.append(\""
                                 out "\")\nfrom argparse")))
-              (copy-file "couger" (string-append out "/bin/couger")))
+              (install-file "couger" bin))
             #t))
          (add-after
           'install 'wrap-program
@@ -2231,8 +2230,7 @@ quantitative phenotypes.")
                     (let ((target (string-append (assoc-ref outputs "out")
                                                  "/bin")))
                       (mkdir-p target)
-                      (copy-file "edirect.pl"
-                                 (string-append target "/edirect.pl"))
+                      (install-file "edirect.pl" target)
                       #t)))
          (add-after
           'install 'wrap-program
@@ -2378,10 +2376,8 @@ ChIP-Seq, and analysis of metagenomic data.")
                    (let ((bin (string-append (assoc-ref outputs "out")
                                              "/bin")))
                      (mkdir-p bin)
-                     (copy-file "scripts/convertToEBD.py"
-                                (string-append bin "/convertToEBD.py"))
-                     (copy-file "bin/ExpressBetaDiversity"
-                                (string-append bin "/ExpressBetaDiversity"))
+                     (install-file "scripts/convertToEBD.py" bin)
+                     (install-file "bin/ExpressBetaDiversity" bin)
                      #t))))))
    (inputs
     `(("python" ,python-2)))
@@ -2440,10 +2436,8 @@ similarity of community members.")
             (let ((bin (string-append (assoc-ref outputs "out")
                                       "/bin")))
               (mkdir-p bin)
-              (copy-file "FastTree"
-                         (string-append bin "/FastTree"))
-              (copy-file "FastTreeMP"
-                         (string-append bin "/FastTreeMP"))
+              (install-file "FastTree" bin)
+              (install-file "FastTreeMP" bin)
               #t))))))
    (home-page "http://www.microbesonline.org/fasttree")
    (synopsis "Infers approximately-maximum-likelihood phylogenetic trees")
@@ -4101,11 +4095,9 @@ phylogenies.")
                       (mkdir-p bin)
                       (mkdir-p perl)
                       (for-each (lambda (file)
-                                  (copy-file file
-                                             (string-append bin (basename file))))
+                                  (install-file file bin))
                                 (find-files "." "rsem-.*"))
-                      (copy-file "rsem_perl_utils.pm"
-                                 (string-append perl "/rsem_perl_utils.pm")))
+                      (install-file "rsem_perl_utils.pm" perl))
                     #t))
          (add-after
           'install 'wrap-program
@@ -4336,8 +4328,7 @@ viewer.")
                    (let ((bin (string-append
                                (assoc-ref outputs "out") "/bin")))
                      (mkdir-p bin)
-                     (copy-file "samtools"
-                                (string-append bin "/samtools"))
+                     (install-file "samtools" bin)
                      #t)))
                (delete 'patch-tests)
                (delete 'configure))))))))
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index f91fdab153..3aaa754c09 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -271,13 +271,13 @@ features that are not supported by the standard @code{stdio} implementation.")
          (replace
           'install
           (lambda* (#:key outputs #:allow-other-keys)
-            (let ((out (assoc-ref outputs "out")))
-              (mkdir-p (string-append out "/lib"))
-              (mkdir (string-append out "/include"))
-              (copy-file "src/withershins.hpp"
-                         (string-append out "/include/withershins.hpp"))
-              (copy-file "src/libwithershins.a"
-                         (string-append out "/lib/libwithershins.a")))
+            (let* ((out (assoc-ref outputs "out"))
+                   (include (string-append out "/include"))
+                   (lib (string-append out "/lib")))
+              (mkdir-p include)
+              (install-file "src/withershins.hpp" include)
+              (mkdir-p lib)
+              (install-file "src/libwithershins.a" lib))
             #t)))))
     (home-page "https://github.com/cameronwhite/withershins")
     (inputs
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index dbc4795d02..576a70af75 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -45,6 +45,7 @@
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages backup)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages check)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
@@ -1173,3 +1174,87 @@ or junctions, and always follows hard links.")
     (description "Unrar is a simple command-line program to list and extract
 RAR archives.")
     (license license:gpl2+)))
+
+(define-public zstd
+  (package
+    (name "zstd")
+    (version "1.1.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/facebook/zstd/archive/v"
+                                  version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "02mgk7cbyksfx7mq95cykghb7dya797z0n2jxr5fx9j0x0m56v0h"))
+              (modules '((guix build utils)))
+              (snippet
+               ;; Remove non-free source files.
+               '(begin
+                  (for-each delete-file-recursively
+                            (list
+                             ;; Commercial use of the following is not allowed.
+                             "examples"
+                             "LICENSE-examples"))
+                  #t))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (delete 'configure))           ; no configure script
+       #:make-flags
+       (list "CC=gcc"
+             (string-append "PREFIX=" (assoc-ref %outputs "out")))
+       #:test-target "test"))
+    (home-page "http://zstd.net/")
+    (synopsis "Zstandard real-time compression algorithm")
+    (description "Zstandard (@command{zstd}) is a lossless compression algorithm
+that combines very fast operation with a compression ratio comparable to that of
+zlib.  In most scenarios, both compression and decompression can be performed in
+‘real time’.  The compressor can be configured to provide the most suitable
+trade-off between compression ratio and speed, without affecting decompression
+speed.")
+    (license (list license:bsd-3         ; the main top-level LICENSE file
+                   license:bsd-2         ; quite a few files have but 2 clauses
+                   license:public-domain ; zlibWrapper/examples/fitblk*
+                   license:zlib))))      ; zlibWrapper/{gz*.c,gzguts.h}
+
+(define-public pzstd
+  (package
+    (name "pzstd")
+    (version (package-version zstd))
+    (source (package-source zstd))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("googletest", googletest)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'enter-subdirectory
+           (lambda _ (chdir "contrib/pzstd")))
+         (delete 'configure)            ; no configure script
+         (add-before 'check 'compile-tests
+           (lambda* (#:key make-flags #:allow-other-keys)
+             (zero? (apply system* "make" "tests" make-flags))))
+         (add-after 'install 'install-documentation
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (doc (string-append out "/share/doc/" ,name)))
+               (mkdir-p doc)
+               (install-file "README.md" doc)
+               #t))))
+       #:make-flags
+       (list "CC=gcc"
+             (string-append "PREFIX=" (assoc-ref %outputs "out")))))
+    (home-page (package-home-page zstd))
+    (synopsis "Threaded implementation of the Zstandard compression algorithm")
+    (description "Parallel Zstandard (PZstandard or @command{pzstd}) is a
+multi-threaded implementation of the @uref{http://zstd.net/, Zstandard
+compression algorithm}.  It is fully compatible with the original Zstandard file
+format and command-line interface, and can be used as a drop-in replacement.
+
+Compression is distributed over multiple processor cores to improve performance,
+as is the decompression of data compressed in this manner.  Data compressed by
+other implementations will only be decompressed by two threads: one performing
+the actual decompression, the other input and output.")
+    (license (package-license zstd))))
diff --git a/gnu/packages/conky.scm b/gnu/packages/conky.scm
index 9c933a4bc0..1f5b38eef4 100644
--- a/gnu/packages/conky.scm
+++ b/gnu/packages/conky.scm
@@ -64,7 +64,7 @@
          (lambda* (#:key outputs #:allow-other-keys)
            (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
              (mkdir-p bin)
-             (copy-file "src/conky" (string-append bin "/conky"))))
+             (install-file "src/conky" bin)))
          %standard-phases))))
     (inputs
      `(("freetype" ,freetype)
diff --git a/gnu/packages/cryptsetup.scm b/gnu/packages/cryptsetup.scm
index da58facffb..900b004a50 100644
--- a/gnu/packages/cryptsetup.scm
+++ b/gnu/packages/cryptsetup.scm
@@ -32,7 +32,7 @@
 (define-public cryptsetup
   (package
    (name "cryptsetup")
-   (version "1.7.3")
+   (version "1.7.4")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://kernel.org/linux/utils/cryptsetup/v"
@@ -40,7 +40,7 @@
                                 "/" name "-" version ".tar.xz"))
             (sha256
              (base32
-              "00nwd96m9yq4k3cayc04i5y7iakkzana35zxky6hpx2w8zl08axg"))))
+              "05m0ric8anrkl62smk8rafgi30j9jrxw20qzss9gnf4sywz8kkvw"))))
    (build-system gnu-build-system)
    (inputs
     `(("libgcrypt" ,libgcrypt)
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 6278f661ef..27193c8bba 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -68,10 +68,10 @@
               (mkdir-p bin)
               (mkdir-p doc)
               (for-each (lambda (h)
-                          (copy-file h (string-append doc "/" (basename h))))
+                          (install-file h doc))
                         `("License.txt" ,@(find-files "www" ".*\\.html")))
               (for-each (lambda (b)
-                          (copy-file b (string-append bin "/" b)))
+                          (install-file b bin))
                         `("delta" "multidelta" "topformflat")))))
         (alist-delete 'configure %standard-phases))))
     (home-page "http://delta.tigris.org/")
@@ -212,13 +212,13 @@ tools that process C/C++ code.")
                                       (system* "tar" "xf"
                                                (assoc-ref inputs "afl-src")))
                                (error "tar failed to unpack afl-src"))
-                             (copy-file (string-append patch-dir
-                                                       "/afl-qemu-cpu-inl.h")
-                                        "./afl-qemu-cpu-inl.h")
+                             (install-file (string-append patch-dir
+                                                          "/afl-qemu-cpu-inl.h")
+                                           ".")
                              (copy-file (string-append afl-dir "/config.h")
                                         "./afl-config.h")
-                             (copy-file (string-append afl-dir "/types.h")
-                                        "./types.h")
+                             (install-file (string-append afl-dir "/types.h")
+                                           ".")
                              (substitute* "afl-qemu-cpu-inl.h"
                                (("\\.\\./\\.\\./config.h") "afl-config.h"))
                              (substitute* (string-append patch-dir
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 3db5527e60..c6e62acb7a 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -2101,7 +2101,7 @@ to a key in your preferred mode.")
         ;; keep only file of interest
         '(begin
            (for-each delete-file '("dot-emacs.el" "Makefile"))
-           (copy-file "6.945-config/mit-scheme-doc.el" "mit-scheme-doc.el")
+           (install-file "6.945-config/mit-scheme-doc.el" ".")
            (delete-file-recursively "6.945-config")))
        (file-name (string-append name "-" version ".tar.bz2"))
        (method url-fetch)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 23446bafa8..dd56af99da 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -96,13 +96,13 @@
                                            (assoc-ref inputs "boost")))))
         (replace 'install
          (lambda* (#:key outputs #:allow-other-keys)
-           (let ((out (assoc-ref outputs "out")))
-             (mkdir-p (string-append out "/bin"))
-             (mkdir-p (string-append out "/share/librecad"))
-             (copy-file "unix/librecad"
-                        (string-append out "/bin/librecad"))
-             (copy-recursively "unix/resources"
-                               (string-append out "/share/librecad"))))))))
+           (let* ((out   (assoc-ref outputs "out"))
+                  (bin   (string-append out "/bin"))
+                  (share (string-append out "/share/librecad")))
+             (mkdir-p bin)
+             (install-file "unix/librecad" bin)
+             (mkdir-p share)
+             (copy-recursively "unix/resources" share)))))))
     (inputs
      `(("boost" ,boost)
        ("muparser" ,muparser)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 234e40c281..3c305f4b2a 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -49,7 +49,7 @@
 (define-public bitcoin-core
   (package
     (name "bitcoin-core")
-    (version "0.13.0")
+    (version "0.14.0")
     (source (origin
              (method url-fetch)
              (uri
@@ -57,7 +57,7 @@
                              version "/bitcoin-" version ".tar.gz"))
              (sha256
               (base32
-               "1nhw2s8p1hg6715l6kc1c7psqhkzfwhfrrgiar17zccvd14p0z8c"))))
+               "07k4i9r033dsvkp5ii5g3hykidm8b19c8c0mz1bi8k0dda3d8hyp"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f8152e0184..f264ef206f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -19,7 +19,7 @@
 ;;; Copyright © 2016 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
 ;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
 ;;; Copyright © 2016 Albin Söderqvist <albin@fripost.org>
-;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
+;;; Copyright © 2016, 2017 Kei Kebreau <kei@openmailbox.org>
 ;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
@@ -73,6 +73,7 @@
   #:use-module (gnu packages libunwind)
   #:use-module (gnu packages haskell)
   #:use-module (gnu packages mp3)
+  #:use-module (gnu packages music)
   #:use-module (gnu packages icu4c)
   #:use-module (gnu packages image)
   #:use-module (gnu packages ncurses)
@@ -195,6 +196,50 @@ scriptable with Guile.")
 Chess).  It is similar to standard chess but this variant is far more complicated.")
     (license license:gpl3+)))
 
+(define-public prboom-plus
+  (package
+   (name "prboom-plus")
+   (version "2.5.1.4")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "mirror://sourceforge/" name "/" name "/"
+                                version "/" name "-" version ".tar.gz"))
+            (sha256
+             (base32
+              "151v6nign86m1a2vqz27krsccpc9m4d1jax4y43v2fa82wfj9qp0"))
+            (modules '((guix build utils)))
+            (snippet
+             '(substitute* "src/version.c"
+                           (("__DATE__") "")
+                           (("__TIME__") "")))))
+   (build-system gnu-build-system)
+   (arguments
+    '(#:configure-flags '("--disable-cpu-opt")
+      #:make-flags `(,(string-append "gamesdir="
+                                     (assoc-ref %outputs "out") "/bin"))
+      #:phases
+      (modify-phases %standard-phases
+        (add-after 'set-paths 'set-sdl'paths
+          (lambda* (#:key inputs #:allow-other-keys)
+            (setenv "CPATH"
+                    (string-append (assoc-ref inputs "sdl-union")
+                                   "/include/SDL"))
+            #t)))))
+   (inputs
+    `(("fluidsynth" ,fluidsynth)
+      ("glu" ,glu)
+      ("libmad" ,libmad)
+      ("libpng" ,libpng)
+      ("libvorbis" ,libvorbis)
+      ("pcre" ,pcre)
+      ("portmidi" ,portmidi)
+      ("sdl-union" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-net)))))
+   (home-page "http://prboom-plus.sourceforge.net/")
+   (synopsis "Version of the classic 3D shoot'em'up game Doom")
+   (description
+    "PrBoom+ is a Doom source port developed from the original PrBoom project.")
+   (license license:gpl2+)))
+
 (define-public xshogi
   (package
     (name "xshogi")
@@ -3190,7 +3235,7 @@ to the Space Age.")
 (define-public no-more-secrets
   (package
     (name "no-more-secrets")
-    (version "0.3.0")
+    (version "0.3.2")
     (source
      (origin
        (method url-fetch)
@@ -3199,7 +3244,7 @@ to the Space Age.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "038flwqr0kqv55im2v76xjn01zbvvkb3nzb5ridwm2kbnk9cgg4v"))))
+         "00mzdif859vm75n1igrffh8c07p1nr4rlm3yb7lrkwwxhrw8xzla"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 5425ab9c75..59de06b62f 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -220,15 +220,15 @@ without requiring the source code to be rewritten.")
 (define-public guile-next
   (package (inherit guile-2.0)
     (name "guile-next")
-    (version "2.1.8")
+    (version "2.2.0")
     (replacement #f)
     (source (origin
               (method url-fetch)
-              (uri (string-append "ftp://alpha.gnu.org/gnu/guile/guile-"
-                                  version ".tar.xz"))
+              (uri (string-append "mirror://gnu/guile/guile-" version
+                                  ".tar.lz"))
               (sha256
                (base32
-                "0rh9vahqqwbyj79p1lc9pljkgxg8rczczf074dr8wl13j5h0y27m"))
+                "083vp6754dp4d5pvcy4bqvxq60cayf92v5slf5cgij8bnvixgyvr"))
               (modules '((guix build utils)))
 
               ;; Remove the pre-built object files.  Instead, build everything
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index fa8a3aae6b..3bf0e66479 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -107,14 +107,14 @@
 (define-public mailutils
   (package
     (name "mailutils")
-    (version "3.1.1")
+    (version "3.2")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/mailutils/mailutils-"
                                  version ".tar.bz2"))
              (sha256
               (base32
-               "1dpylyg79avi7brpkcmzaq7bqqkz45flp0ws6f2c8b1gyz4hdnzm"))))
+               "0c06yj5hgqibi24ib9sx865kq6i1h18wn201g6iwcfbpi2a7psdm"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 3763292fe4..38986cdce1 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -134,7 +134,7 @@ the traditional flat-text whatis databases.")
 (define-public man-pages
   (package
     (name "man-pages")
-    (version "4.09")
+    (version "4.10")
     (source (origin
               (method url-fetch)
               (uri
@@ -147,7 +147,7 @@ the traditional flat-text whatis databases.")
                     "man-pages-" version ".tar.xz")))
               (sha256
                (base32
-                "1740gq9sq28dp5a5sjn1ya7cvrv8mbky6knb7734v8k29a7a0x55"))))
+                "1yk3ibmbc1wamw798lqw8lh203xnrjddy8wdk5d3hifmj71xz5bk"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases (alist-delete 'configure %standard-phases)
@@ -161,7 +161,7 @@ the traditional flat-text whatis databases.")
        #:make-flags (list (string-append "MANDIR="
                                          (assoc-ref %outputs "out")
                                          "/share/man"))))
-    (home-page "http://www.kernel.org/doc/man-pages/")
+    (home-page "https://www.kernel.org/doc/man-pages/")
     (synopsis "Development manual pages from the Linux project")
     (description
      "This package provides traditional Unix \"man pages\" documenting the
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index d274d50bbc..03567ba083 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -185,13 +185,13 @@ programming languages.")
 (define-public units
   (package
    (name "units")
-   (version "2.13")
+   (version "2.14")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/units/units-" version
                                 ".tar.gz"))
             (sha256 (base32
-                     "1awhjw9zjlfb8s5g3yyx63f7ddfcr1sanlbxpqifmrgq24ql198b"))))
+                     "1s421bxm36akjsy3qzg6da1d1g20gh094ac2slqxipgkh8yqjcwx"))))
    (build-system gnu-build-system)
    (synopsis "Conversion between thousands of scales")
    (description
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 4e40567b1c..7aa7b7bfe5 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -8,6 +8,7 @@
 ;;; Copyright © 2016, 2017 <contact.ng0@cryptolab.net>
 ;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
 ;;; Copyright © 2016, 2017 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -43,6 +44,7 @@
   #:use-module (gnu packages base)
   #:use-module (gnu packages check)
   #:use-module (gnu packages crypto)
+  #:use-module (gnu packages curl)
   #:use-module (gnu packages cyrus-sasl)
   #:use-module (gnu packages databases)
   #:use-module (gnu packages documentation)
@@ -1222,4 +1224,109 @@ is also scriptable and extensible via Guile.")
     (home-page "https://www.gnu.org/software/freetalk")
     (license license:gpl3+)))
 
+(define-public libmesode
+  (package
+    (name "libmesode")
+    (version "0.9.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/boothj5/libmesode/archive/"
+                                  version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0iaj56fkd5bjvqpvq3324ni895rmbj1akbfqipjydnghfwaym4z6"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'bootstrap
+           (lambda _
+             (zero? (system* "./bootstrap.sh")))))))
+    (inputs
+     `(("expat" ,expat)
+       ("openssl" ,openssl)))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)))
+    (synopsis "C library for writing XMPP clients")
+    (description "Libmesode is a fork of libstrophe for use with Profanity
+XMPP Client.  In particular, libmesode provides extra TLS functionality such as
+manual SSL certificate verification.")
+    (home-page "https://github.com/boothj5/libmesode")
+    ;; Dual licensed.
+    (license (list license:gpl3+ license:x11))))
+
+(define-public libstrophe
+  (package
+    (name "libstrophe")
+    (version "0.9.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/strophe/libstrophe/archive/"
+                                  version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1hzwdax4nsz0fncf5bjfza0cn0lc6xsf38y569ql1gg5hvwr6169"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'bootstrap
+           (lambda _
+             (zero? (system* "./bootstrap.sh")))))))
+    (inputs
+     `(("expat" ,expat)
+       ("openssl" ,openssl)))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)))
+    (synopsis "C library for writing XMPP clients")
+    (description "Libstrophe is a minimal XMPP library written in C.  It has
+almost no external dependencies, only an XML parsing library (expat or libxml
+are both supported).")
+    (home-page "http://strophe.im/libstrophe")
+    ;; Dual licensed.
+    (license (list license:gpl3+ license:x11))))
+
+(define-public profanity
+    (package
+        (name "profanity")
+        (version "0.5.1")
+        (source (origin
+                  (method url-fetch)
+                  (uri (string-append "http://www.profanity.im/profanity-"
+                                      version ".tar.gz"))
+                  (sha256
+                   (base32
+                     "1f7ylw3mhhnii52mmk40hyc4kqhpvjdr3hmsplzkdhsfww9kflg3"))))
+        (build-system gnu-build-system)
+        (inputs
+         `(("curl" ,curl)
+           ("expat" ,expat)
+           ("glib" ,glib)
+           ("gpgme" ,gpgme)
+           ("libmesode" ,libmesode)
+           ("libotr" ,libotr)
+           ("ncurses" ,ncurses)
+           ("openssl" ,openssl)
+           ("readline" ,readline)))
+        (native-inputs
+         `(("autoconf" ,autoconf)
+           ("autoconf-archive" ,autoconf-archive)
+           ("automake" ,automake)
+           ("cmocka" ,cmocka)
+           ("libtool" ,libtool)
+           ("pkg-config" ,pkg-config)))
+        (synopsis "Console-based XMPP client")
+        (description "Profanity is a console based XMPP client written in C
+using ncurses and libmesode, inspired by Irssi.")
+        (home-page "http://www.profanity.im")
+        (license license:gpl3+)))
+
 ;;; messaging.scm ends here
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 95253687cd..e36903b8af 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1141,3 +1141,28 @@ IPFIX, RSPAN, CLI, LACP, 802.1ag).")
      "Command line interface for testing internet bandwidth using
 speedtest.net.")
     (license license:asl2.0)))
+
+(define-public tftp-hpa
+  (package
+    (name "tftp-hpa")
+    (version "5.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://kernel.org/software/"
+                                  "network/tftp/tftp-hpa/tftp-hpa-" version
+                                  ".tar.xz"))
+              (sha256
+               (base32
+                "12vidchglhyc20znq5wdsbhi9mqg90jnl7qr9qs8hbvaz4fkdvmg"))))
+    (build-system gnu-build-system)
+    (arguments `(#:tests? #f)) ; no test target
+    (synopsis "HPA's tftp client")
+    (description
+     "This is a tftp client derived from OpenBSD tftp with some extra options
+added and bugs fixed.  The source includes readline support but it is not
+enabled due to license conflicts between the BSD advertising clause and the GPL.")
+    (home-page "http://git.kernel.org/cgit/network/tftp/tftp-hpa.git/about/")
+    ;; Some source files are distributed under a 3-clause BSD license, and
+    ;; others under a 4-clause BSD license. Refer to the files in the source
+    ;; distribution for clarification.
+    (license (list license:bsd-3 license:bsd-4))))
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2b1255c2ec..be452f0627 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6521,7 +6521,7 @@ markdown_py is also provided to convert Markdown files to HTML.")
 (define-public python-ptyprocess
   (package
     (name "python-ptyprocess")
-    (version "0.5")
+    (version "0.5.1")
     (source
      (origin
        (method url-fetch)
@@ -6530,7 +6530,7 @@ markdown_py is also provided to convert Markdown files to HTML.")
              version ".tar.gz"))
        (sha256
         (base32
-         "0nggns5kikn32yyda2zrj1xdmh49pi3v0drggcdwljbv36r8zdyw"))))
+         "19l1xrjn4l9gjz01s3vg92gn2dd9d8mw1v86ppkzlnr9m5iwwc05"))))
     (build-system python-build-system)
     (native-inputs
      `(("python-nose" ,python-nose)))
@@ -9304,14 +9304,14 @@ document.")
 (define-public python-botocore
   (package
    (name "python-botocore")
-   (version "1.5.10")
+   (version "1.5.26")
    (source
     (origin
      (method url-fetch)
      (uri (pypi-uri "botocore" version))
      (sha256
       (base32
-       "1hqvqwhgfcch4knm1l02ynx7qd1igxk3pj34c1x2b0r79jca524n"))))
+       "1b7l48hr88galrrc5q6k21z3sdadzxc87ppzs7k9fz4p1w8bfnvb"))))
    (build-system python-build-system)
    (arguments
     ;; FIXME: Many tests are failing.
@@ -9338,14 +9338,14 @@ interface to the Amazon Web Services (AWS) API.")
 (define-public awscli
   (package
    (name "awscli")
-   (version "1.11.47")
+   (version "1.11.63")
    (source
     (origin
      (method url-fetch)
      (uri (pypi-uri name version))
      (sha256
       (base32
-       "0p0pila0k99fm87q1gb24wyd34ags0vkh37h1fa6hklq4mi69i1w"))))
+       "1r8aqv8w27k76lcsfk83w6qw9lz8gk2ibzwacp5wjhpp2gik911m"))))
    (build-system python-build-system)
    (propagated-inputs
     `(("python-colorama" ,python-colorama)
@@ -12042,14 +12042,14 @@ List.")
 (define-public python-publicsuffix2
   (package
     (name "python-publicsuffix2")
-    (version "2.20160621")
+    (version "2.20160818")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "publicsuffix2" version ".tar.bz2"))
        (sha256
         (base32
-         "06lx603gdwad5hc3hmn763ngq0rq9bzz1ni3ga72nzk5n872arkd"))))
+         "1bb55yka9vkn7i6y1kjzxa516kh6v4gsrxa90w5wdz5p5n968r68"))))
     (build-system python-build-system)
     (arguments
      '(#:tests? #f)) ; The test suite requires network access.