summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 03:16:58 -0400
committerMark H Weaver <mhw@netris.org>2018-03-23 04:43:05 -0400
commit5f70b6d4e8128f8366a6ac2d1caaf23ad7bb8043 (patch)
tree0667fe80c04d24856a001768e418217df1e3131d /gnu/packages
parent6073ef75083c3faedaf2a889659e4c61c7b25090 (diff)
downloadguix-5f70b6d4e8128f8366a6ac2d1caaf23ad7bb8043.tar.gz
gnu: mozjs@38: Use invoke.
* gnu/packages/gnuzilla.scm (mozjs-38)[arguments]: Use invoke in the custom
configure phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnuzilla.scm32
1 files changed, 16 insertions, 16 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 0f75319387..8a6a66d594 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -225,23 +225,23 @@ in C/C++.")
                (chdir "js/src")
                (setenv "SHELL" (which "sh"))
                (setenv "CONFIG_SHELL" (which "sh"))
-               (zero? (system* "./configure"
-                               (string-append "--prefix=" out)
-                               "--enable-ctypes"
-                               "--enable-gcgenerational"
-                               "--enable-optimize"
-                               "--enable-pie"
-                               "--enable-readline"
-                               "--enable-shared-js"
-                               "--enable-system-ffi"
-                               "--enable-threadsafe"
-                               "--enable-xterm-updates"
-                               "--with-system-icu"
-                               "--with-system-nspr"
-                               "--with-system-zlib"
+               (invoke "./configure"
+                       (string-append "--prefix=" out)
+                       "--enable-ctypes"
+                       "--enable-gcgenerational"
+                       "--enable-optimize"
+                       "--enable-pie"
+                       "--enable-readline"
+                       "--enable-shared-js"
+                       "--enable-system-ffi"
+                       "--enable-threadsafe"
+                       "--enable-xterm-updates"
+                       "--with-system-icu"
+                       "--with-system-nspr"
+                       "--with-system-zlib"
 
-                               ;; Intl API requires bundled ICU.
-                               "--without-intl-api"))))))))
+                       ;; Intl API requires bundled ICU.
+                       "--without-intl-api")))))))
     (native-inputs
      `(("perl" ,perl)
        ("pkg-config" ,pkg-config)