summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-08 19:06:14 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-08 19:21:27 +0200
commit68ee10da03b09c2acead8891e4b51c718c24d574 (patch)
tree9212316b3668828d11ffb5646eb2b7b52ce47b1c /gnu/packages
parenta4edd9ad05821284f532cb912e757955cf656f7e (diff)
downloadguix-68ee10da03b09c2acead8891e4b51c718c24d574.tar.gz
gnu: xf86-video-r128: Fix FTBFS with xorg-server >= 1.20.
* gnu/packages/xorg.scm (xf86-video-r128): Update to 6.10.2-0.c4c878d.
[source]: Use GIT-FETCH.
[arguments]: Add 'prevent-configure' phase.
[native-inputs]: Add AUTOCONF, AUTOMAKE and LIBTOOL.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/xorg.scm64
1 files changed, 39 insertions, 25 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index ba3b68020a..993c004887 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -3175,33 +3175,47 @@ This driver is intended for the spice qxl virtio device.")
     (home-page "http://www.spice-space.org")
     (license license:x11)))
 
-
 (define-public xf86-video-r128
-  (package
-    (name "xf86-video-r128")
-    (version "6.10.2")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (string-append
-               "mirror://xorg/individual/driver/xf86-video-r128-"
-               version
-               ".tar.bz2"))
-        (sha256
-          (base32
-           "1pkpka5m4cd6iy0f8iqnmg6xci14nb6887ilvxzn3xrsgx8j3nl4"))))
-    (build-system gnu-build-system)
-    (inputs `(("mesa" ,mesa)
-              ("xorgproto" ,xorgproto)
-              ("xorg-server" ,xorg-server)))
-    (native-inputs `(("pkg-config" ,pkg-config)))
-    (home-page "https://www.x.org/wiki/")
-    (synopsis "ATI Rage 128 video driver for X server")
-    (description
-     "xf86-video-r128 is a video driver for the Xorg X server.
+  ;; We need a newer version than 6.10.2 to build against the latest xorg-server.
+  ;; Remove this binding and the bootstrap inputs when >6.10.2 is released.
+  (let ((commit "c4c878d2ccb75fa75afe46e0e50ee9975c5c57fc")
+        (revision "0"))
+    (package
+      (name "xf86-video-r128")
+      (version (git-version "6.10.2" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url (string-append "https://anongit.freedesktop.org/git/xorg"
+                                          "/driver/" name ".git"))
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "01pff30zz4zxjhw28h8bn9x2kq7c6iswgn19b72wnfgl0arxb63j"))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:phases (modify-phases %standard-phases
+                    (add-before 'bootstrap 'prevent-configure
+                      (lambda _
+                        ;; Prevent autogen from calling "./configure" as part of
+                        ;; the bootstrap step, which fails due to wrong shebang.
+                        (setenv "NOCONFIGURE" "1")
+                        #t)))))
+      (inputs `(("mesa" ,mesa)
+                ("xorgproto" ,xorgproto)
+                ("xorg-server" ,xorg-server)))
+      (native-inputs
+       `(("pkg-config" ,pkg-config)
+         ("autoconf" ,autoconf)
+         ("automake" ,automake)
+         ("libtool" ,libtool)))
+      (home-page "https://www.x.org/wiki/")
+      (synopsis "ATI Rage 128 video driver for X server")
+      (description
+       "xf86-video-r128 is a video driver for the Xorg X server.
 This driver is intended for ATI Rage 128 based cards.")
-    (license license:x11)))
-
+      (license license:x11))))
 
 (define-public xf86-video-savage
   (package