summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-27 11:01:21 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-27 12:48:39 +0200
commit8d7e7ca6a1c801aa636cfc1767b8839fef77c97e (patch)
tree5457e974a14d57aff6890ed6377eb4446119ebde /gnu/packages
parent619848558e3bb15ee53c1576eb97d4d100a1ca5f (diff)
downloadguix-8d7e7ca6a1c801aa636cfc1767b8839fef77c97e.tar.gz
gnu: python-click: Enable tests.
* gnu/packages/python-xyz.scm (python-click)[arguments]: Enable tests.
Add custom 'check phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1592c46a2f..e9b8b94053 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1648,10 +1648,7 @@ files.")
          "1mzjixd4vjbjvzb6vylki9w1556a9qmdh35kzmq6cign46av952v"))))
     (build-system python-build-system)
     (arguments
-     `(;; The tests are fragile, depending on a specific version of pytest:
-       ;; <https://github.com/pallets/click/issues/823>
-       #:tests? #f
-       #:phases
+     `(#:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'fix-paths
            (lambda* (#:key inputs #:allow-other-keys)
@@ -1660,7 +1657,10 @@ files.")
                (substitute* "click/_unicodefun.py"
                  (("'locale'")
                   (string-append "'" glibc "/bin/locale'"))))
-             #t)))))
+             #t))
+         (replace 'check
+           (lambda _
+             (invoke "python" "-m" "pytest"))))))
     (native-inputs
      `(("python-pytest" ,python-pytest)))
     (home-page "https://palletsprojects.com/p/click/")