summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-06 10:52:34 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-06 11:21:56 +0100
commit8e5e26d2abbc19e715f948d05fbd253cb83843f0 (patch)
treec9aef6f87e6eb92a6200b97c9b17a2dc86c1bc1f /gnu/packages
parent7fe49f2a8a1bc42e644d00871b0472ccf3a961cf (diff)
downloadguix-8e5e26d2abbc19e715f948d05fbd253cb83843f0.tar.gz
gnu: Add r-webshot.
* gnu/packages/cran.scm (r-webshot): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8492b9581b..418043d79c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1972,3 +1972,29 @@ parallel coordinate displays by some merit index.  It contains various indices
 of merit, ordering functions, and enhanced versions of @code{pairs} and
 @code{parcoord} which color panels according to their merit level.")
     (license license:gpl2+)))
+
+(define-public r-webshot
+  (package
+    (name "r-webshot")
+    (version "0.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "webshot" version))
+       (sha256
+        (base32
+         "07r71zzmggp4jf92x4ws4wg6v1x98vaj01lsar85bnb30n5vx8gh"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-jsonlite" ,r-jsonlite)
+       ("r-magrittr" ,r-magrittr)
+       ("r-processx" ,r-processx)
+       ("r-withr" ,r-withr)))
+    (home-page "https://github.com/wch/webshot/")
+    (synopsis "Take screenshots of web pages")
+    (description
+     "Webshot makes it easy to take screenshots of web pages from within R.
+It can also run Shiny applications locally and take screenshots of the
+application; and it can render and screenshot static as well as interactive R
+Markdown documents.")
+    (license license:gpl2)))