summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-02-20 17:43:08 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-02 11:32:10 +0100
commita2fb1492afe9e22102ee2404f1b546ee655ec7ac (patch)
treeb2d32b02228d8f226e9b8a3470dd6e4b102ea1a4 /gnu/packages
parent8d12be1eb1226d795e260558168a9756b6900259 (diff)
downloadguix-a2fb1492afe9e22102ee2404f1b546ee655ec7ac.tar.gz
gnu: Add pybedtools.
* gnu/packages/bioinformatics.scm (python2-pybedtools): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b64dab73cd..a919da8b51 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -141,6 +141,39 @@ intervals from multiple files in widely-used genomic file formats such as BAM,
 BED, GFF/GTF, VCF.")
     (license license:gpl2)))
 
+(define-public python2-pybedtools
+  (package
+    (name "python2-pybedtools")
+    (version "0.6.9")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://pypi.python.org/packages/source/p/pybedtools/pybedtools-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "1ldzdxw1p4y3g2ignmggsdypvqkcwqwzhdha4rbgpih048z5p4an"))))
+    (build-system python-build-system)
+    (arguments `(#:python ,python-2)) ; no Python 3 support
+    (inputs
+     `(("python-cython" ,python2-cython)
+       ("python-matplotlib" ,python2-matplotlib)))
+    (propagated-inputs
+     `(("bedtools" ,bedtools)
+       ("samtools" ,samtools)))
+    (native-inputs
+     `(("python-pyyaml" ,python2-pyyaml)
+       ("python-nose" ,python2-nose)
+       ("python-setuptools" ,python2-setuptools)))
+    (home-page "https://pythonhosted.org/pybedtools/")
+    (synopsis "Python wrapper for BEDtools programs")
+    (description
+     "pybedtools is a Python wrapper for Aaron Quinlan's BEDtools programs,
+which are widely used for genomic interval manipulation or \"genome algebra\".
+pybedtools extends BEDTools by offering feature-level manipulations from with
+Python.")
+    (license license:gpl2+)))
+
 (define-public bowtie
   (package
     (name "bowtie")