summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-02-15 23:10:58 +0100
committerAndreas Enge <andreas@enge.fr>2015-02-15 23:10:58 +0100
commitd3d656c5fbd9345e7f9d62564a06d1672300625c (patch)
treebeb43d682a9103220792d50a4d2b0e44ae6e20a7 /gnu/packages
parent431d32e688b8b38ec17dbcc5ad38e793fcd4b2e2 (diff)
downloadguix-d3d656c5fbd9345e7f9d62564a06d1672300625c.tar.gz
gnu: python-setuptools: Update to 12.1.
*  gnu/packages/python.scm (python-setuptools, python2-setuptools):
     Update to 12.1.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 984ec9a458..6fe524e83a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -376,7 +376,7 @@ have been used.")
 (define-public python-setuptools
   (package
     (name "python-setuptools")
-    (version "1.1.4")
+    (version "12.1")
     (source
      (origin
       (method url-fetch)
@@ -384,14 +384,12 @@ have been used.")
                           version ".tar.gz"))
       (sha256
        (base32
-        "0hl9sa5xr9bi2ifq51wy1bawsjv5nzvpbac7m9z1ciz778874csf"))))
+        "04bfk7si1pwj3b5k2b1x9b1zkiclybmzpw6alrs5bciri56lg9zs"))))
     (build-system python-build-system)
+    ;; FIXME: Tests require pytest, which itself relies on setuptools.
+    ;; One could bootstrap with an internal untested setuptools.
     (arguments
      `(#:tests? #f))
-         ;;FIXME: test_sdist_with_utf8_encoded_filename fails in
-         ;; /tmp/nix-build-python2-setuptools-1.1.4.drv-0/setuptools-1.1.4/setuptools/tests/test_sdist.py"
-         ;; line 354
-         ;; The tests pass with Python 2.7.5.
     (home-page "https://pypi.python.org/pypi/setuptools")
     (synopsis
      "Library designed to facilitate packaging Python projects")