summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-03-01 22:21:53 +0100
committerLudovic Courtès <ludo@gnu.org>2015-03-01 22:22:43 +0100
commitec35d364959078ac8e452db3ddc09ff0143d89da (patch)
treeae3b04ad6c42ff3c55d058d361000d918febe1f4 /gnu/packages
parent9041d935c42b537e7423630fc1030f59a649a3d4 (diff)
downloadguix-ec35d364959078ac8e452db3ddc09ff0143d89da.tar.gz
gnu: libpsl: Fix link flag in 'libpsl.pc'.
* gnu/packages/web.scm (libpsl)[source]: Add 'snippet' and 'modules'
  fields.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/web.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 5296c43c53..fd1d6dd4c7 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -248,7 +248,12 @@ for efficient socket-like bidirectional reliable communication channels.")
               (sha256
                (base32
                 "10s7xxxx6pp4ydp3san69sa6q379ih3pv92fyi565ggmlw8igv7a"))
-              (file-name (string-append name "-" version ".tar.gz"))))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (modules '((guix build utils)))
+              (snippet
+               ;; Believe it or not, the .pc is invalid.  Fix it.
+               '(substitute* "libpsl.pc.in"
+                  (("-llibpsl") "-lpsl")))))
     (build-system gnu-build-system)
     (inputs `(("icu4c" ,icu4c)))
     ;; The release tarball lacks the generated files.