summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 18:38:52 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:31 +0100
commite2dc97d69ad68733ffdc0a8576a9b881eceff2e3 (patch)
tree22835c431725f4bb42e40f61edb3ae769902a304 /gnu/packages
parentb90f72dcf8b8176c54361151c23f92948bc2102f (diff)
downloadguix-e2dc97d69ad68733ffdc0a8576a9b881eceff2e3.tar.gz
gnu: ghc: Use ghc-8 as default GHC.
* gnu/packages/haskell.scm (ghc): Rename variable...
(ghc-7): ...to this.
(ghc-8)[native-inputs]: Adjust accordingly.
(ghc): New alias for ghc-8.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index a6a49548c4..654f4dfec2 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -136,7 +136,7 @@ top of CLISP.")
 ;;
 ;; - Test posix010 tries to check the existence of a user on the system:
 ;;   getUserEntryForName: does not exist (no such user)
-(define-public ghc
+(define-public ghc-7
   (package
     (name "ghc")
     (version "7.10.2")
@@ -346,7 +346,7 @@ interactive environment for the functional language Haskell.")
        ("python" ,python-2)                ; for tests
        ("ghostscript" ,ghostscript)        ; for tests
        ;; GHC is built with GHC.
-       ("ghc-bootstrap" ,ghc)))
+       ("ghc-bootstrap" ,ghc-7)))
     (arguments
      `(#:test-target "test"
        ;; We get a smaller number of test failures by disabling parallel test
@@ -423,6 +423,8 @@ interactive environment for the functional language Haskell.")
 interactive environment for the functional language Haskell.")
     (license license:bsd-3)))
 
+(define-public ghc ghc-8)
+
 (define-public ghc-hostname
   (package
     (name "ghc-hostname")