summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-20 17:56:06 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-20 17:56:06 +0100
commit49057c8fc17e0f7135a98a57f2bdd338b96cb536 (patch)
tree76fdf925734a01babe2eeaaa5d3e16d68a318522 /gnu/packages
parent7c9a1d5e8056a566780a2c2a026127d40096fa56 (diff)
downloadguix-49057c8fc17e0f7135a98a57f2bdd338b96cb536.tar.gz
Revert "gnu: python2-tqdm: Work around missing flake8 propagation."
This reverts commit 53f826cd0f429864d46fc3bf6305c14356d0b2ad.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b03382ca17..3e410b0a51 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11979,18 +11979,10 @@ ignoring formatting changes.")
       "Make loops show a progress bar on the console by just wrapping any
 iterable with @code{|tqdm(iterable)|}.  Offers many options to define
 design and layout.")
-    (license (list license:mpl2.0 license:expat))
-    (properties `((python2-variant . ,(delay python2-tqdm))))))
+    (license (list license:mpl2.0 license:expat))))
 
 (define-public python2-tqdm
-  (let ((tqdm (package-with-python2
-               (strip-python2-variant python-tqdm))))
-    (package
-      (inherit tqdm)
-      (native-inputs
-       ;; FIXME: This should be propagated from python2-flake8 instead.
-       `(("python2-enum34" ,python2-enum34)
-         ,@(package-native-inputs tqdm))))))
+  (package-with-python2 python-tqdm))
 
 (define-public python-pkginfo
   (package