summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 18:53:42 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:07 +0300
commit55d5321093672badf7d003787204640692124324 (patch)
treeab911cd2bcfc07f6899705eb4ebf60b0770519ed /gnu/packages
parentde8d99128995e694027f73f99beee6851324c623 (diff)
downloadguix-55d5321093672badf7d003787204640692124324.tar.gz
gnu: Add emacs-biblio.
* gnu/packages/emacs.scm (emacs-biblio): New public variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 9a48bfd50f..9058bf2821 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -8182,3 +8182,27 @@ outline-mode), so there is no such thing like an outshine mode, only
     (description
      "This package provides an Emacs library for parsing bib files.")
     (license license:gpl3+)))
+
+(define-public emacs-biblio
+  (package
+    (name "emacs-biblio")
+    (version "0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/cpitclaudel/biblio.el/archive/"
+                           version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "109fvivsb4r0rbqljngqrmxqvbnbkqlivczx6brrvlr7ci625lhf"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/cpitclaudel/biblio.el")
+    (synopsis "Browse and import bibliographic references")
+    (description "This package provides an extensible Emacs package for
+browsing and fetching references.
+
+@file{biblio.el} makes it easy to browse and gather bibliographic references
+and publications from various sources, by keywords or by DOI.  References are
+automatically fetched from well-curated sources, and formatted as BibTeX.")
+    (license license:gpl3+)))