summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-07-24 12:08:51 -0400
committerLeo Famulari <leo@famulari.name>2019-07-29 14:57:05 -0400
commita85a78eb249d33a1d8cc4ac9de6b2db0c34b932b (patch)
tree061a1894e6deaae8bd137ab21dc5ac19b677ab7d /gnu/packages
parent371b70429919850d8eed0151be82e84673f806a4 (diff)
downloadguix-a85a78eb249d33a1d8cc4ac9de6b2db0c34b932b.tar.gz
gnu: go-github-com-golang-protobuf-proto: Update to 1.3.1.
* gnu/packages/syncthing.scm (go-github-com-golang-protobuf-proto):
Update to 1.3.1.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/syncthing.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index a18121c598..256cd2429c 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -841,20 +841,18 @@ bounds.")
       (license expat))))
 
 (define-public go-github-com-golang-protobuf-proto
-  (let ((commit "1e59b77b52bf8e4b449a57e6f79f21226d571845")
-        (revision "0"))
     (package
       (name "go-github-com-golang-protobuf-proto")
-      (version (git-version "0.0.0" revision commit))
+      (version "1.3.1")
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
                        (url "https://github.com/golang/protobuf.git")
-                       (commit commit)))
+                       (commit (string-append "v" version))))
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "19bkh81wnp6njg3931wky6hsnnl2d1ig20vfjxpv450sd3k6yys8"))))
+                  "15am4s4646qy6iv0g3kkqq52rzykqjhm4bf08dk0fy2r58knpsyl"))))
       (build-system go-build-system)
       (arguments
        '(#:import-path "github.com/golang/protobuf/proto"
@@ -865,7 +863,7 @@ bounds.")
       (description "This package provides Go support for the Protocol Buffers
 data serialization format.")
       (home-page "https://github.com/golang/protobuf")
-      (license bsd-3))))
+      (license bsd-3)))
 
 (define-public go-github-com-prometheus-client-model-go
   (let ((commit "fd36f4220a901265f90734c3183c5f0c91daa0b8")