summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-04 13:23:05 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-09 18:18:44 +0000
commitd5f56e9089aa743e12f54163a879c17eab48380e (patch)
treecdab970f700c11484d94c35505a11e8527823281 /gnu/packages
parenta9079b488037371f90514b82961dc075ea0b3985 (diff)
downloadguix-d5f56e9089aa743e12f54163a879c17eab48380e.tar.gz
gnu: Add python-djangorestframework.
* gnu/packages/django.scm (python-djangorestframework): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/django.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index c52c812f00..f944d25b60 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -755,3 +755,27 @@ Django projects, which allows association of a number of tags with any
 
 (define-public python2-django-tagging
   (package-with-python2 python-django-tagging))
+
+(define-public python-djangorestframework
+  (package
+    (name "python-djangorestframework")
+    (version "3.7.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "djangorestframework" version))
+       (sha256
+        (base32
+         "11qv117gqwswxjljs7wafxg1hyzzlx3qrviwlk9hw41bsbl997lz"))))
+    (build-system python-build-system)
+    (arguments
+     '(;; No included tests
+       #:tests? #f))
+    (propagated-inputs
+     `(("python-django" ,python-django)))
+    (home-page "https://www.django-rest-framework.org")
+    (synopsis "Toolkit for building Web APIs with Django")
+    (description
+     "The Django REST framework is for building Web APIs with Django.  It
+provides features like a web browseable API and authentication policies.")
+    (license license:bsd-2)))