summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-05-15 21:50:30 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-05-15 22:08:34 +0200
commit0094c4fa9116817865fccc5c3618f13dd380fa54 (patch)
treef8317359e5dcecad3f8de3c1f8236532ac785f22 /gnu/packages
parentcb014f64a50c3c832858b8927de334740f83b8a5 (diff)
downloadguix-0094c4fa9116817865fccc5c3618f13dd380fa54.tar.gz
gnu: kicad: Update to 5.1.6.
* gnu/packages/engineering.scm (kicad): Update to 5.1.6.
[source]: Use GIT-FETCH & GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/engineering.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index f80ea02e30..fd85c4f20a 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -800,16 +800,16 @@ language.")
 (define-public kicad
   (package
     (name "kicad")
-    (version "5.1.5")
+    (version "5.1.6")
     (source
      (origin
-       (method url-fetch)
-       (file-name (string-append name "-" version ".tar.xz"))
-       (uri (string-append
-             "https://launchpad.net/kicad/" (version-major version)
-             ".0/" version "/+download/kicad-" version ".tar.xz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.com/kicad/code/kicad.git")
+             (commit version)))
        (sha256
-        (base32 "0x3417f2pa7p65s9f7l49rqbnrzy8gz6i0n07mlbxqbnm0fmlql0"))))
+        (base32 "1pa3z0h0679jmgxlzc833h6q85b5paxdp69kf2h93vkaryj58622"))
+       (file-name (git-file-name name version))))
     (build-system cmake-build-system)
     (arguments
      `(#:out-of-source? #t