summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-12-19 11:06:34 +0100
committerRutger Helling <rhelling@mykolab.com>2018-12-19 11:51:33 +0100
commit34f1838f04c7c359da8dbba86817499630ce7f01 (patch)
treee41a74ed2c9c58989004cbe34c31061fa36dff5d /gnu/packages
parent12878d12acccf83ef3258a53a01f851088f0aa9e (diff)
downloadguix-34f1838f04c7c359da8dbba86817499630ce7f01.tar.gz
gnu: vulkan-headers: Update to 1.1.96.
* gnu/packages/vulkan.scm (vulkan-headers): Update to 1.1.96.
* gnu/packages/vulkan.scm (vulkan-loader): Update hash.
* gnu/packages/vulkan.scm (vulkan-tools): Update hash.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/vulkan.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 3608196e5d..f346d155dc 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -163,16 +163,16 @@ interpretation of the specifications for these languages.")
 (define-public vulkan-headers
   (package
     (name "vulkan-headers")
-    (version "1.1.92.0")
+    (version "1.1.96")
     (source
      (origin
        (method url-fetch)
        (uri (string-append
              "https://github.com/KhronosGroup/Vulkan-Headers/"
-             "archive/sdk-" version ".tar.gz"))
+             "archive/v" version ".tar.gz"))
        (sha256
         (base32
-         "06bgiz1dnp57597vd26r2smsadpcnr425n9gfdbp6xm4wba4l5l9"))))
+         "1mr15v7d7lxi7qjkgwyvy2s3a5k2xd7y8x40dd2al3a3c4chl2y2"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f)) ; No tests.
@@ -186,17 +186,16 @@ interpretation of the specifications for these languages.")
 (define-public vulkan-loader
   (package
     (name "vulkan-loader")
-    ;; TODO: Inherit from vulkan-headers when version numbers match again
-    (version "1.1.92.1")
+    (version (package-version vulkan-headers))
     (source
      (origin
        (method url-fetch)
        (uri (string-append
              "https://github.com/KhronosGroup/Vulkan-Loader/"
-             "archive/sdk-" version ".tar.gz"))
+             "archive/v" version ".tar.gz"))
        (sha256
         (base32
-         "1kx07ypbwnmn6cxv9z0vbngq5l83f1sffzh7wmkzrl69y1cmazi0"))))
+         "11jg678sj8yykr3n1km0638l6737iyhsl4x4q1zwbwyiifm0w89z"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f ;FIXME: 23/39 tests fail.  Try "tests/run_all_tests.sh".
@@ -249,10 +248,10 @@ and the ICD.")
        (method url-fetch)
        (uri (string-append
              "https://github.com/KhronosGroup/Vulkan-Tools/"
-             "archive/sdk-" version ".tar.gz"))
+             "archive/v" version ".tar.gz"))
        (sha256
         (base32
-         "0yd9dgkyradlk9gx0ps65nans7b29jg5c67b4m34ghpmy933dwx6"))))
+         "066v0vfhcqcwzlijvvs3jrbldp5kdqgwydkn7k2wrbcgynr77h8q"))))
     (build-system cmake-build-system)
     (inputs
      `(("glslang" ,glslang)