summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-12 22:27:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-12 22:47:57 +0100
commit5570804a69f6cf8a69f6da24411c99b129130893 (patch)
treee0aa56f7d54a8e7a75e95ebeb572f4a2387d3cb5 /gnu/packages
parentbe0777ba865550e3bc80d6ef962e230233bae45f (diff)
downloadguix-5570804a69f6cf8a69f6da24411c99b129130893.tar.gz
gnu: Add r-zim.
* gnu/packages/cran.scm (r-zim): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0c789dd69f..b41e456735 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11288,3 +11288,31 @@ are linear, logistic and Poisson regression and the Cox Proportional Hazards
 model.  Cross-validation routines allow optimization of the tuning
 parameters.")
     (license license:gpl2+)))
+
+(define-public r-zim
+  (package
+    (name "r-zim")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ZIM" version))
+       (sha256
+        (base32
+         "0scyfjn4ilsvha3x41c3b8bcfi31hlhwm77wn2a8hj5dsvnnmzig"))))
+    (properties `((upstream-name . "ZIM")))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-mass" ,r-mass)))
+    (home-page "https://github.com/biostatstudio/ZIM")
+    (synopsis "Zero-inflated models (ZIM) for count time series with excess zeros")
+    (description
+     "Analyze count time series with excess zeros.  Two types of statistical
+models are supported: Markov regression and state-space models.  They are also
+known as observation-driven and parameter-driven models respectively in the
+time series literature.  The functions used for Markov regression or
+observation-driven models can also be used to fit ordinary regression models
+with independent data under the zero-inflated Poisson (ZIP) or zero-inflated
+negative binomial (ZINB) assumption.  The package also contains miscellaneous
+functions to compute density, distribution, quantile, and generate random
+numbers from ZIP and ZINB distributions.")
+    (license license:gpl3)))