summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-09-12 16:12:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-09-12 17:44:46 +0200
commita589acfb08882cf7978d53a21d0ed27926b44a4e (patch)
tree342f747593744e9814a1f72b64ee3852c3a56456 /gnu/packages
parent348bb8d6631f3c288777c3a9fb26061dd26de91d (diff)
downloadguix-a589acfb08882cf7978d53a21d0ed27926b44a4e.tar.gz
gnu: Add r-tibble.
* gnu/packages/statistics.scm (r-tibble): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/statistics.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index d658c8f44f..d6b57b7fa7 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1078,6 +1078,29 @@ private members, and they support inheritance, even when the classes are
 defined in different packages.")
     (license license:expat)))
 
+(define-public r-tibble
+  (package
+    (name "r-tibble")
+    (version "1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "tibble" version))
+       (sha256
+        (base32
+         "011i352ylq9b4xfcj7h10h7qsqd9qkc1rzc0pr1gf8qjb788p2pd"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-assertthat" ,r-assertthat)
+       ("r-lazyeval" ,r-lazyeval)
+       ("r-rcpp" ,r-rcpp)))
+    (home-page "https://github.com/hadley/tibble")
+    (synopsis "Simple data frames")
+    (description
+     "This package provides a @code{tbl_df} class that offers better checking
+and printing capabilities than traditional data frames.")
+    (license license:expat)))
+
 (define-public r-dplyr
   (package
     (name "r-dplyr")