summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2018-04-20 01:06:37 +0530
committerArun Isaac <arunisaac@systemreboot.net>2018-04-20 01:09:46 +0530
commit1848cdfb7d8ce9fb78ffc9f6771689ff9ff7e333 (patch)
tree866cc415becee75c25e459d8930e1f878831b223 /gnu/packages
parentbf5c74e713c623cbb0001eb36af6998e92243482 (diff)
downloadguix-1848cdfb7d8ce9fb78ffc9f6771689ff9ff7e333.tar.gz
gnu: emacs-memoize: Update to 1.1.
* gnu/packages/emacs.scm (emacs-memoize): Update to 1.1. Re-indent.
[source]: Switch to release tarball.
[arguments]: Remove "-l" "memoize.el" from #:test-command.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm45
1 files changed, 22 insertions, 23 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 81173947c6..5f7107ea7e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -5170,30 +5170,29 @@ Yasnippet.")
 
 (define-public emacs-memoize
   (package
-   (name "emacs-memoize")
-   (version "20130421.b55eab0")
-   (source
-    (origin
-     (method git-fetch)
-     (uri (git-reference
-           (url "https://github.com/skeeto/emacs-memoize")
-           (commit "b55eab0cb6ab05d941e07b8c01f1655c0cf1dd75")))
-     (file-name (string-append name "-" version ".tar.gz"))
-     (sha256
-      (base32
-       "0fjwlrdm270qcrqffvarw5yhijk656q4lam79ybhaznzj0dq3xpw"))))
-   (build-system emacs-build-system)
-   (arguments
-    `(#:tests? #t
-      #:test-command '("emacs" "-batch"
-                       "-l" "memoize.el"
-                       "-l" "memoize-test.el"
-                       "-f" "ert-run-tests-batch-and-exit")))
-   (home-page "https://github.com/skeeto/emacs-memoize")
-   (synopsis "Emacs lisp memoization library")
-   (description "@code{emacs-memoize} is an Emacs library for
+    (name "emacs-memoize")
+    (version "1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/skeeto/emacs-memoize/archive/"
+             version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "05ijgwi4ymxx31vpjm2pn356j85cykknajn14lrzz8pn5sh0vrg4"))))
+    (build-system emacs-build-system)
+    (arguments
+     `(#:tests? #t
+       #:test-command '("emacs" "--batch"
+                        "-l" "memoize-test.el"
+                        "-f" "ert-run-tests-batch-and-exit")))
+    (home-page "https://github.com/skeeto/emacs-memoize")
+    (synopsis "Emacs lisp memoization library")
+    (description "@code{emacs-memoize} is an Emacs library for
 memoizing functions.")
-   (license license:unlicense)))
+    (license license:unlicense)))
 
 (define-public emacs-linum-relative
   (package