summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2020-05-26 14:50:10 -0500
committerEric Bavier <bavier@member.fsf.org>2020-05-26 14:50:10 -0500
commit5c133ca561acfc1a1b9fe6dfc03d2bd12784242c (patch)
treeac15f7bd5da7710588448b71638e2fe487a9ea96 /gnu/packages
parent981d80b331afc39365ccf393684b9b94cd0eaec0 (diff)
downloadguix-5c133ca561acfc1a1b9fe6dfc03d2bd12784242c.tar.gz
gnu: netsurf: Update to 3.10.
* gnu/packages/web.scm (netsurf): Update to 3.10.
* gnu/packages/patches/netsurf-system-utf8proc.patch: Adjust to new source.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/netsurf-system-utf8proc.patch51
-rw-r--r--gnu/packages/web.scm4
2 files changed, 9 insertions, 46 deletions
diff --git a/gnu/packages/patches/netsurf-system-utf8proc.patch b/gnu/packages/patches/netsurf-system-utf8proc.patch
index a2ee52ca05..04bf828f37 100644
--- a/gnu/packages/patches/netsurf-system-utf8proc.patch
+++ b/gnu/packages/patches/netsurf-system-utf8proc.patch
@@ -1,50 +1,13 @@
-Use upstream utf8proc package, as suggested in
-http://source.netsurf-browser.org/libutf8proc.git/commit/?id=770e329cceaf0620c7b482589a9b17ed1d19c16d
+Fix include directory for system utf8proc.
 
-Work around upstream's lack of a pkg-config file and update API.
-
---- netsurf-3.6/Makefile
-+++ netsurf-3.6/Makefile
-@@ -527,10 +527,9 @@
- $(eval $(call pkg_config_find_and_add,libcss,CSS))
- $(eval $(call pkg_config_find_and_add,libdom,DOM))
- $(eval $(call pkg_config_find_and_add,libnsutils,nsutils))
--$(eval $(call pkg_config_find_and_add,libutf8proc,utf8proc))
- 
- # Common libraries without pkg-config support
--LDFLAGS += -lz
-+LDFLAGS += -lz -lutf8proc
+--- netsurf-3.10/utils/idna.c
++++ netsurf-3.10/utils/idna.c
+@@ -167,7 +167,7 @@
  
- # Optional libraries with pkgconfig
+ #ifdef WITH_UTF8PROC
  
---- netsurf-3.8/utils/idna.c
-+++ netsurf-3.8/utils/idna.c
-@@ -27,7 +27,7 @@
- #include <stdlib.h>
- #include <string.h>
- #include <sys/types.h>
 -#include <libutf8proc/utf8proc.h>
 +#include <utf8proc.h>
  
- #include "netsurf/inttypes.h"
- 
---- netsurf-3.8/test/Makefile
-+++ netsurf-3.8/test/Makefile
-@@ -142,14 +142,15 @@
- 	-Itest -Iinclude -Icontent/handlers -Ifrontends -I. -I.. \
- 	-Dnsgtk \
- 	$(SAN_FLAGS) \
--	$(shell pkg-config --cflags libcurl libparserutils libwapcaplet libdom libnsutils libutf8proc) \
-+	$(shell pkg-config --cflags libcurl libparserutils libwapcaplet libdom libnsutils) \
- 	$(LIB_CFLAGS)
- TESTCFLAGS := $(BASE_TESTCFLAGS) \
- 	$(COV_CFLAGS) \
- 	$(COV_CPPFLAGS)
- 
- TESTLDFLAGS := -L$(TESTROOT) \
--	$(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils libutf8proc) -lz \
-+	$(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils) \
-+	$(LDFLAGS) \
- 	$(SAN_FLAGS) \
- 	$(LIB_LDFLAGS)\
- 	$(COV_LDFLAGS)
+ int32_t idna_contexto[] = {
+ 	/* CONTEXTO codepoints which have a rule defined */
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 68b0336781..d8290ff53a 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5247,7 +5247,7 @@ w3c webidl files and a binding configuration file.")
 (define-public netsurf
   (package
     (name "netsurf")
-    (version "3.9")
+    (version "3.10")
     (source
      (origin
        (method url-fetch)
@@ -5255,7 +5255,7 @@ w3c webidl files and a binding configuration file.")
                            "releases/source/netsurf-" version "-src.tar.gz"))
        (sha256
         (base32
-         "1hzcm2s2wh5sapgr000lg63hcdbj6hyajxl43xa1x80kc5piqbyp"))
+         "0plra64c5xyiw12yx2q13brxsv8apmany97zqa2lcqckw4ll8j1n"))
        (patches (search-patches "netsurf-system-utf8proc.patch"
                                 "netsurf-y2038-tests.patch"
                                 "netsurf-longer-test-timeout.patch"