summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-01 12:32:16 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-01 13:32:11 +0200
commitad430c7127557bc8235e0f5010a04de85f81239e (patch)
tree80c57aef0a8ae941b1254e49918ecf31e1895b25 /gnu/packages
parent0027e09415c9f764ad0656f74350907ca5a0075d (diff)
downloadguix-ad430c7127557bc8235e0f5010a04de85f81239e.tar.gz
gnu: xdotool: Update to 3.20160805.1.
* gnu/packages/xdisorg.scm (xdotool): Update to 3.20160805.1.
[source](patches): Remove.
[arguments]: Create output directory.
* gnu/packages/patches/xdotool-fix-makefile.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/xdotool-fix-makefile.patch16
-rw-r--r--gnu/packages/xdisorg.scm15
2 files changed, 7 insertions, 24 deletions
diff --git a/gnu/packages/patches/xdotool-fix-makefile.patch b/gnu/packages/patches/xdotool-fix-makefile.patch
deleted file mode 100644
index 5fed41f8b4..0000000000
--- a/gnu/packages/patches/xdotool-fix-makefile.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Fix Makefile, which missed including a necessary library for compiling in the
-0.5.0 release.
-
-See https://github.com/jordansissel/xdotool/pull/81 for more information.
-
---- xdotool-3.20150503.1/Makefile	2014-10-20 13:05:34.000000000 -0700
-+++ xdotool-3.20150503.1/Makefile	2016-02-05 14:44:18.652734272 -0800
-@@ -28,7 +28,7 @@
- CFLAGS+=-g # TODO(sissel): Comment before release
- CFLAGS+=$(CPPFLAGS)
- 
--DEFAULT_LIBS=-L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXtst -lXinerama
-+DEFAULT_LIBS=-L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXtst -lXinerama -lxkbcommon
- DEFAULT_INC=-I/usr/X11R6/include -I/usr/local/include
- 
- XDOTOOL_LIBS=$(shell pkg-config --libs x11 2> /dev/null || echo "$(DEFAULT_LIBS)")  $(shell sh platform.sh extralibs)
\ No newline at end of file
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 59ac02f79f..d6ca5278f5 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -222,7 +222,7 @@ X11 (yet).")
 (define-public xdotool
   (package
     (name "xdotool")
-    (version "3.20150503.1")
+    (version "3.20160805.1")
     (source
       (origin
         (method url-fetch)
@@ -231,8 +231,7 @@ X11 (yet).")
               version "/xdotool-" version ".tar.gz"))
         (sha256
           (base32
-           "1lcngsw33fy9my21rdiz1gs474bfdqcfxjrnfggbx4aypn1nhcp8"))
-        (patches (search-patches "xdotool-fix-makefile.patch"))))
+           "1a6c1zr86zb53352yxv104l76l8x21gfl2bgw6h21iphxpv5zgim"))))
     (build-system gnu-build-system)
     (arguments
      '(#:tests? #f ; Test suite requires a lot of black magic
@@ -240,11 +239,11 @@ X11 (yet).")
        (modify-phases %standard-phases
          (replace 'configure
            (lambda* (#:key outputs #:allow-other-keys #:rest args)
-             (setenv "PREFIX" (assoc-ref outputs "out"))
-             (setenv "LDFLAGS"
-                     (string-append "-Wl,-rpath="
-                                    (assoc-ref %outputs "out") "/lib"))
-             (setenv "CC" "gcc"))))))
+             (let ((out (assoc-ref outputs "out")))
+               (mkdir-p (string-append out "/lib"))
+               (setenv "PREFIX" out)
+               (setenv "LDFLAGS" (string-append "-Wl,-rpath=" out "/lib"))
+               (setenv "CC" "gcc")))))))
     (native-inputs `(("perl" ,perl))) ; for pod2man
     (inputs `(("libx11" ,libx11)
               ("libxext" ,libxext)