summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-07-16 14:43:29 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-07-20 16:27:54 +0300
commit099516cb3b4e054dd52258625af3027ef609e0c2 (patch)
tree283ff8717cc0012b417c7068ffd4b29f3f05b39c /gnu/packages
parent381ea2b443a56ce60fe98c393c1e7dafceb6af33 (diff)
downloadguix-099516cb3b4e054dd52258625af3027ef609e0c2.tar.gz
gnu: python-click: Update to 7.1.2.
* gnu/packages/python-xyz.scm (python-click): Update to 7.1.2.
[arguments] Fix the name of the file to modify. Set PYTHONPATH to make tests pass.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c6afe0b03d..f55f888254 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2429,14 +2429,14 @@ interfaces.")
 (define-public python-click
   (package
     (name "python-click")
-    (version "7.0")
+    (version "7.1.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "click" version))
        (sha256
         (base32
-         "1mzjixd4vjbjvzb6vylki9w1556a9qmdh35kzmq6cign46av952v"))))
+         "06kbzd6sjfkqan3miwj9wqyddfxc2b6hi7p5s4dvqjb3gif2bdfj"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -2445,12 +2445,13 @@ interfaces.")
            (lambda* (#:key inputs #:allow-other-keys)
              (let ((glibc (assoc-ref inputs ,(if (%current-target-system)
                                                  "cross-libc" "libc"))))
-               (substitute* "click/_unicodefun.py"
+               (substitute* "src/click/_unicodefun.py"
                  (("'locale'")
                   (string-append "'" glibc "/bin/locale'"))))
              #t))
          (replace 'check
            (lambda _
+             (setenv "PYTHONPATH" (string-append "./src:" (getenv "PYTHONPATH")))
              (invoke "python" "-m" "pytest"))))))
     (native-inputs
      `(("python-pytest" ,python-pytest)))