summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-02-17 17:12:56 +0000
committerChristopher Baines <mail@cbaines.net>2019-03-04 20:33:20 +0000
commit29dc48231d510837b5f41ad080a9b49090c4aa2b (patch)
tree20a095f3c9b3e31ec2fe3f9276b278d060e47782 /gnu/packages
parent92b3750059f3e9a0b4998788af20399e990897dc (diff)
downloadguix-29dc48231d510837b5f41ad080a9b49090c4aa2b.tar.gz
gnu: Add ruby-omniauth.
* gnu/packags/ruby.scm (ruby-omniauth): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 7adaca8144..946eef1fcc 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1201,6 +1201,30 @@ with a similar style to the original OAuth spec.")
     (home-page "https://github.com/oauth-xx/oauth2")
     (license license:expat)))
 
+(define-public ruby-omniauth
+  (package
+    (name "ruby-omniauth")
+    (version "1.9.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "omniauth" version))
+       (sha256
+        (base32
+         "1p16h1rp8by05k8gfw17xjhgwp60dk8qmj1xalv1n23kmxfsxb1x"))))
+    (build-system ruby-build-system)
+    (arguments
+     '(#:tests? #f)) ; No included tests
+    (propagated-inputs
+     `(("ruby-hashie" ,ruby-hashie)
+       ("ruby-rack" ,ruby-rack)))
+    (synopsis "Generalized Rack framework for multiple-provider authentication")
+    (description
+     "This package provides a generalized Rack framework for multiple-provider
+authentication.")
+    (home-page "https://github.com/omniauth/omniauth")
+    (license license:expat)))
+
 (define-public ruby-open4
   (package
   (name "ruby-open4")