summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-12 13:06:32 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-12 15:55:58 -0500
commite3ad9d64d6e25207f3a489a0643ab0e56fcc0f03 (patch)
tree9bfe0943d1d9c24d8777eae5948016482cd358b9 /gnu/packages
parent895046f935dd75fad2b62b258f0817b2f8ada631 (diff)
downloadguix-e3ad9d64d6e25207f3a489a0643ab0e56fcc0f03.tar.gz
gnu: Add Text-SimpleTable.
* gnu/packages/perl.scm (perl-text-simpletable): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/perl.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 26f40f92bb..beb7f8dce8 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2822,6 +2822,24 @@ used to match against text, rather than fetching names from a filesystem.  If
 you want to do full file globbing use the File::Glob module instead.")
     (license (package-license perl))))
 
+(define-public perl-text-simpletable
+  (package
+    (name "perl-text-simpletable")
+    (version "2.03")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/M/MR/MRAMBERG/"
+                           "Text-SimpleTable-" version ".tar.gz"))
+       (sha256
+        (base32
+         "15hpry9jwrf1vbjyk21s65rllxrdvp2fdzzv9gsvczggby2yyzfs"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Text-SimpleTable")
+    (synopsis "Simple ASCII tables")
+    (description "Text::SimpleTable draws simple ASCII tables.")
+    (license artistic2.0)))
+
 (define-public perl-time-local
   (package
     (name "perl-time-local")